[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#49962: Debian FSS-upgrade process: man pages

On Nov 12, Andreas Krüger wrote:
> In short:
> A reasonably new version of "man-db" should be required on
> my system automatically, through Debian package dependencies,
> whenever I install any Debian package that has FSS man pages.

Unfortunately, a dependency forces everyone to install man-db; some
people may not need a man page reader.  Ideally dpkg needs a
"Depends-If-Installed" control field to handle this situation.

However, I think it *would* be possible for FHS packages to Conflict
with man-db prior to the necessary version.  It's sort of an abuse of
the dependency system (since there's no real conflict, per se), but it
would at least work, I think.

|       Chris Lawrence       |   You have a computer.  Do you have Linux?   |
|  <quango@watervalley.net>  |     http://www.linux-m68k.org/index.html     |
|                            |                                              |
|      Debian Developer      |    Signatures generated by Signify v1.06.    |
|   http://www.debian.org/   |       More info: http://www.debian.org/      |

Reply to: