[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Something wrong with potato modutils



Previously Vaidhyanathan G Mayilrangam wrote:
> I have the same problem. I upgraded my potato machine yesterday. I had
> a bunch of unresolved symbols. I did a update-modules. Now my machine
> is complaining about /etc/modules.conf being older than
> /lib/modules/2.2.5/modules.dep.

It's a warning which can be safely ignored. modules.dep is remade on
boot, while modules.conf is only generated when needed. As a result it
tends to be older, which triggers this warning.

> Somehow, the depmod -a from init.d script seems to be not writing the
> modules.dep. When I run depmod -a manually, the modules.dep gets
> created. Next time, I boot, there is a old modules.dep in my
> /lib/modules.

How you have me confused.. how can the script not write modules.dep
while you still get the error that modules.conf is older then that
file? Something doesn't add up here..

Wichert.

-- 
   ________________________________________________________________
 / Generally uninteresting signature - ignore at your convenience  \
| wichert@liacs.nl                    http://www.liacs.nl/~wichert/ |
| 1024D/2FA3BC2D 576E 100B 518D 2F16 36B0  2805 3CB8 9250 2FA3 BC2D |

Attachment: pgp7MxxzsiXU1.pgp
Description: PGP signature


Reply to: