[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unstable release

On Mon, Oct 04, 1999 at 08:44:48PM +0200, Staffan Hämälä was heard to say:
> Hi,
> I'm just curious about how other people succeed in installing the
> potato release.

  *raises hand*

  I've actually done two things -- the machine I'm typing on has been running
unstable since before Slink was frozen, so it's been continuously upgraded for
a while.  However, I've also upgraded existing Slink systems and installed new
systems (sort of, see below)

> Myself, I have always had _lots_ of trouble when
> trying that. First, I installed it at home, and dselect freaked
> out and started complaining over files that didn't exist. This
> was due to the fact that ftp downloads the softlinks that point
> to slink packages instead of the actual files. That time I had
> downloaded the whole lot with ncftp. I downloaded another time
> using wget with the option to get real files. That worked better,
> and dselect found all files. Still, the big problem was dselect
> because it complained about so many things it flipped out and
> refused to install any more packages (I barely got a working
> system).

  I usually use apt to fetch via ftp, but pointing it at a source archive
should do the same thing.  Are you using it as a dselect backend, or are
you doing something else entirely?

> Last week I tried the same thing at work, installing over ftp,
> and I thik the installer also downloaded just the links, but
> not the actual files, so this time I wasn't even able to boot
> the system after running dselect. After this I installed slink
> instead, and it worked like a charm.

  Wait, you mean you're trying to actually *install* potato?  I didn't realize
that boot-floppies even worked again!  I think it's usually the case that a
from-scratch install doesn't work until the last minute.  I know a Slink
installs I tried last January was totally screwed up (dbootstrap (?) didn't
properly create fstab and I had to put it together by hand -- and that was the
simplest problem.  I got a working system though! :) )

> Of course, I know that it's an unstable release, but is it really
> this hard to install, or is it me doing something wrong?

  Yes and yes :)  I'll describe my methods below..

> How are you installing potato? Is there some magic way
> to make ftp install work when there are soft links on
> the server? Is there a way to make dselect go on installing
> other packages even though it finds ten faulty packages
> first in the list? (This way I could add those ten manually
> afterwards).

  I'll say first that we may have slightly different takes on 'install'; I
wouldn't say that installing potato has to be done with the standard
boot-floppies as long as you end up with a potato system at the end :)

  I do it with a fairly simple approach.  I install the base Slink system, but
on the reboot (after setting a root password :) ) I edit /etc/apt/sources.list
and change all references to "stable" to "unstable".  I then proceed as before.
It may be that the archive is in a weird state at the moment; I haven't done
this for a few months.  I recommend just installing a small set of packages and
then adding stuff by hand in dselect (but I recommend this when setting a new
stable system up as well -- the metapackage/task system is too broken)

  I've never run into problems with this (aside from the usual unstable
weirdness); if you're doing this and encountering trouble, could you be more
precise about what's going on?  apt follows symlinks, as (I believe) does


"In the Course of my Observation, these disputing, contradicting & confuting
 People are generally unfortunate in their Affairs.  They get Victory sometimes,
 but they never get Good Will, which would be of more use to them."
  -- from the autobiography of Benjamin Franklin

Reply to: