[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt bug?

On Wed, 28 Jul 1999, Sarel J. Botha wrote:

> On Tue, Jul 27, 1999 at 11:45:39AM -0700, John Lapeyre wrote:
> > *Turbo Fredriksson wrote:
> > > This just gotta' be a apt bug...
> > > 
> >  I had a similar problem  a couple of times (not related to
> > perl).  Package a depends on package b.  I check b; dpkg -l
> > shows that the correct version of b is installed and configured,
> > but apt will not install a, saying that b needs to be installed.
> > Apt will not install b, because its already the most recent version.
> Is there an apt-get parm that'll make it a bit more verbose on this issue? I
> don't have any funny situations around to test it on. Maybe it would be good
> to print a bit more info if apt-get has to get smarter than X steps to resolve
> an issue ?

There is no possibility of resolution, like the message says - you have
requested an impossible sistuation. The trouble is that it is not easy to
see why - the package APT gives for an error is somewhat non-ideal but
still entirely reasonable.

If you run with -o debug::pkgproblemresolver=true then you can trace the
deductions and see a little better what is wrong.


Reply to: