[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ITP: jvim



Hi.

In <19990620173656.A24016@mors.net>,
 at Sun, 20 Jun 1999 17:36:56 +0200,
  Wichert Akkerman <wichert@cs.leidenuniv.nl> writes:

> Previously Taketoshi Sano wrote:
> > This Package is built using VIM-3.0 and the Japanese patch 1.5b
> > from K. Tsuchida <ken_t@st.rim.or.jp>.
> 
> Let me comment on this as the maintainer of the vim packages :)

Thank you for your comment.

> I have a few questions about this:
> * did you talk with Bram Moolenaar (or even better, the vim-dev list)
>   about merging japanese support with the standard upstream version?

Ah, no. I have not yet contact neither Bram Moolenaar nor vim-dev list.
I hurried too much to think about it. Thanks to point out and remind it 
to me.

# I had thought that I have tried to contact mool@oce.nl, 
# but I can not find out that message in my E-mail archive, 
# so it should be my illusion. sorry.

Merging japanese support with the standard upstream version is
the right way, I think. The only problem is that I don't understand
how to do it myself.

> * are you aware that version 3.0 is really old? The current version is
>   5.3 and 5.4 was just upgraded from alpha to a beta version.

Yes. JP patch for vim 5.0 is still under development. 
Currently JP patch (beta versin) for vim 5.1 seems available via 
http://hp.vector.co.jp/authors/VA003457/vim/vim5/beta/jvim.b5.tar.gz

So I use the current working version of JP patch for vim 3.0.

> * the copyright that you list seems to be the copyright of the current
>   vim 5.3 package, not the vim 3.0 copyright. Is that intentional?

I misunderstand the both are the same, It should be fixed. Thanks.

the README of vim 3.0 said:

  Vim is Charityware. You can copy it as much as you like. Please read
  uganda.txt for details.

and uganda.txt of vim 3.0 said:

  Vim is public domain. If you are happy with Vim and want to express that,
  don't send me money. I don't need it. But I know a place where they do need
  your money. Please read on.

So they should be written in debian/copyright for jvim_3.0-1.5b.
It is my fault to copy the contents from your current vim 5.3.

 !!! Oh, I found now the lines in changelog.Debian of vim_5.3-13, that said

   vim (5.3-12) unstable; urgency=low

    * New license: vim is now fully DFSG-free!

Does this means that vim 3.0's license is not full DFSG compliant ?

Uhm, I should have check the mail-archive,,, Please tell me the pointer
to get the information about this.

# I can not get the result using "Search with Glimpse" on
# http://www.jp.debian.org/Lists-Archives/, keyword: "vim; license",
# list: devel, Dates: Oct to Dec 98. search in Jan to Mar 99 shows 
# some messaages about standard editor, but I can not find the reason
# of conflit between the vim's old license and DFSG.
# Is it not enough to be "public domain" ? 

May be the right way (merge JP support into standard version) is 
the way to go,,, I must consult the previous maintainer in JP project
and the authors of JP patch in vim-jp ML,,,

-- 
  Taketoshi Sano: <kgh12351@nifty.ne.jp>


Reply to: