[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Slink to potato upgrade

Guy Maor wrote:
> Get Ian to implement the dpkg Breaks field.

I'm afraid that won't help us now, since people will be upgrading with
a dpkg that is unaware of this field.

However, I see no semantic difference between Breaks: and a versioned
Conflicts:.  Can we not use conflicts?  We did the libc6 upgrade this
way, and this case is much simpler than that.  (There's no package
shuffling, just forced upgrades.)

Richard Braakman

Reply to: