[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Uploaded boot-floppies 2.1.7 (source all) to erlangen

Le Tue, Feb 16, 1999 at 10:40:07PM -0500, Adam Di Carlo écrivait:
> This statement I agree to.  However, I think we it is not release
> critical to have these sync'd up for slink.  OTOH, we should (in

Of course, it's not.

> general) try to resync base with what is shipped as the base system.
> Here's a list of stuff used for base (I think) which are outside of the base
> system.
> ./devel/popt_1.1.1-3.deb

Is this one used in the base system or is it only used for compiling
dbootstrap ?

I don't think it's installed in the base system :
/usr/src/boot-floppies/scripts/basedisks@p200$ grep popt * 2>/dev/null

> ./devel/gettext_0.10.35-7.deb
> ./shells/ash_0.3.4-6.deb
> ./utils/fdutils_5.2.0.1998-07-01-3.deb
> ./admin/apt_0.1.9.deb
> ./admin/pcmcia-modules-2.0.36_3.0.5-10k2.deb
> ./admin/locales_2.0.7.19981211-5.deb
> ./net/telnet_0.12-4.deb
> ./net/netstd_3.07-7slink.2.deb

I don't see any problems moving these to base. However netstd is not
completely installed in the base system, it's only used for having
/usr/bin/ftp :
/usr/src/boot-floppies/scripts/basedisks@p200$ cat PARTIAL_PACKAGES_all
/usr/src/boot-floppies/scripts/basedisks@p200$ cat PARTIAL_PACKAGE_FILES_all 

We may not move it to base.

> ./interpreters/perl_5.004.04-7.deb

This one is not in the base system and should never go to it. If some
files are needed from perl then you should file a bug against perl and ask
for moving the files from perl to perl-base.

> I don't have a good list for stuff in the base system no longer used
> in base2_1.tgz.

dpkg-ftp is the first. Having a rapid look, I find these one too :
- libnet-perl
- dpkg-mountable
- data-dumper

And also all the kernel-images but that's ok.

> With the approval of people here, I shall submit normal level priority
> bugs against these packages to move them to base.

Go for it, and you can do the same thing probably for packages no more in
the base system. We should also change the priority of those packages,
as most of the packages in base are 'standard' and they don't need to
stay standard ...

Hertzog Raphaël >> 0C4CABF1 >> http://prope.insa-lyon.fr/~rhertzog/

Reply to: