[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: New guile packages



Package: libguile4
Version: 1.3-9
Severity: important

In article <19981209133655.A9710@debian.org>, David Welton <davidw@master.debian.org> writes:
> What bugs?!  Libguile3 == libguile4, at this point.  There is no
> difference.  At the suggestion of others, I created libguile4 to more
> accurately reflect the soname of the lib.  If this wasn't the best
> course of action, it would have been more appropriate to speak up
> then when it was proposed.

> Either way, the lib will have the soname of 4.  This is from the
> upstream maintainer.  It's not even really feasible to generate a new
> libguile3 without hacking the guile-core source package.

In that case, why not be clever and have libguile4
conflict/replace/provide libguile3, and provide a
/usr/lib/libguile.so.3 symlink to /usr/lib/libguile.so.4 ?  I just
tried this manually and suddenly 'siag' works again!

The point is, why force a recompile of a buncha other packages when
there are workarounds to that which better preserve backwards
compatability?

--
.....Adam Di Carlo....adam@onShore.com.....<URL:http://www.onShore.com/>


Reply to: