[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: what's going on with gtk+ ????

On Fri, Dec 04, 1998 at 07:42:24AM -0500, Brian Almeida wrote:
> On Fri, Dec 04, 1998 at 11:01:07AM +0100, Sven LUTHER wrote:
> > i just saw that the new gtk+/glib 1.1.5 are available, but they are now named
> > gtk+/glib1.1.5 instead of gtk+/glib 1.1 as was the case for glib1.1.4 and
> > gtk+1.1.3 ...
> > what is the reason of this ? is it a bug or are there some fundamental
> > difference between both versions, as was between the 1.0 serie and the 1.1 one.
> Because the soname changed.  The way it was going is that when a new gtk+ came
> out it  broke EVERY gtk+1.1 app when the user upgraded to the new one.

ok , ... what is the correct way of doing things now, ... will the soname again
change for gtk+1.2.0, i suppose yes, what about a gtk+1.1.6 ? but then i
suppose such a thing will never exist now that 1.2 is coming.

which one will then be the official gtk version that will be used for compiling
debian packages ? 1.0.6 ? 1.1.x, x<5, 1.1.5, 1.2 when in comes out, supposedly
in december ?

> > yesterday i tried to compile gnome-libs for the powerpc arch, and encoutered
> > some problems regarding this. it seems that all the gtk things are right now
> > compiled against gtk1.0.x, in particular imlib-progs and imlib-dev depend on
> > gtk1-dev, which conflict with gtk1.1-dev, so it is not possible to compile
> > gtk1.1 stuff with gnome ??? i thought latest version of gnome needs gtk1.1 and
> > not gtk1.0, but maybe i am mistaken.
> Uhm. imlib uses gtk+1.1 now. the new gtk+ packages have a Provides: libgtk-dev,
> libgtk1.1-dev, so there shouldn't be an issue there....
> What version of imlib are you using? Also, gnome needs gtk+1.1.

like said this was for the powerpc architecture, so it is possible that some
packages where not the last one, i will download all the sources and recompile
all this stuff, and then i hope this should not be a problem any more. ...

so do i link it against libgtk1.1 or libgtk1.1.5 ? can i have both
libgtk1.1.5-dev and libgtk1.1-dev installed ? i suppose not ...



Reply to: