[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Packages compiled against GTK+1.1 <= 1.1.4 *MUST BE RECOMPILED*!

>>>>> "Robert" == Robert Edmonds <stu@novare.net> writes:

    BG> Any maintainer who has a package in this list must grab the
    BG> new GLib and GTK+ from Incoming and recompile their packages
    BG> for potato. You don't have to upload the fixed packages yet,
    BG> as it's taking a little while for the new GLib and GTK+ to be
    BG> accepted into the archives, but please do the recompile as
    BG> soon as possible.

    Robert> What is this?? I maintain several GTK apps, compiled
    Robert> against GTK+ 1.0.6.  Do I have to recompile these apps??

    Robert> Binary incompatibility sucks ;)

Woops! No; GTK+ 1.0 is stable and unchanging. It's only people who
have packages dependant upon the unstable developers' release of GTK+
1.1 that are going to have problems.

Anyone with a package compiled against GTK+ 1.0 (libgtk1) will have
no problems.


Brought to you by the letters A and Z and the number 5.  "Atatakaku
natta kara, otaku to uchi no kazoku de, nani ka shimasen ka?" -- JSL
Debian GNU/Linux -- where do you want to go tomorrow? 
http://www.debian.org/ I'm on FurryMUCK as Che, and EFNet and YiffNet
IRC as Che_Fox.

Reply to: