[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Switch to perl-5.005_02 ?

"Darren/Torin/Who Ever..." <torin@daft.com> writes:

> Any debian packages and all architecture dependent packages will have to 
> be recompiled.

Since new Perls seem to break binary compatibility, do we need a
better dependency mechanism?

The best option I can see is for perl_5.005 (or perl_base, or
whatever) to Provides: perl5.005.  Packages dependent on the
particular binary formats of that Perl can then depend on the virtual

That should then ensure that when perl_5.006 is available, it won't be
installed until all other packages are available, or unless forced.
(Which could be a problem for trying to compile them... Hmm.)

	 Carey Evans  http://home.clear.net.nz/pages/c.evans/

        "So, do you steal weapons from the Army often?"
        "Well, we don't get cable, so we have to make our own fun."

Reply to: