[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dependency strangeness (dpkg bug?)

Enrique Zanardi <ezanardi@ull.es> writes:

> > Versions of the packages libpgjava depends on:
> > ii  libpgsql        6.3.2-12       Shared library for PostgreSQL
> > ii  jdk1.1          1.1.6v4a-2     JDK 1.1.x (Java Development Kit) - Runtime o
> >         ^^^ (Provides virtual package jdk1.1-runtime)
> > 
> > What's going on here?  Why does dpkg not realize that jdk1.1 is
> > providing jdk1.1-runtime?
> libpgjava needs a particular version of jdk1.1-runtime (>= 1.1.3.v2-1),
> dpkg doesn't undertand "versioned provides" (long standing bug), and a
> "non-versioned provide" isn't enough.

I know one can't do versioned provides.  I thought that dpkg was
simply supposed to ignore the version when dealing with something that 
provides an item that is depended upon?

John Goerzen   Linux, Unix consulting & programming   jgoerzen@complete.org |
Developer, Debian GNU/Linux (Free powerful OS upgrade)       www.debian.org |
Visit the Air Capital Linux Users Group on the web at http://www.aclug.org

Reply to: