[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Dependency strangeness (dpkg bug?)

OK, This is Very Odd (TM):

libpgjava has this:

Depends: jdk1.1-runtime (>= 1.1.3.v2-1), libpgsql (>= 6.3)

Now then, the current runtime is called jdk1.1.  It has this:

Version: 1.1.6v4a-2
Replaces: jdk1.1-runtime
Provides: jdk1.1-runtime
Conflicts: jdk1.1-runtime, jdk1.1-dev (<< 1.1.6v4a-2)
Description: JDK 1.1.x (Java Development Kit) - Runtime only

So one would think everything is OK.  And yet, libpgjava refused to
install without me using --force-depends (it works fine once
installed).  apt continually complains:

Checking system integrity...dependency error
You might want to run `apt-get -f install' to correct these.
Sorry, but the following packages are broken - this means they have unmet
  libpgjava: Depends:jdk1.1-runtime

And yet, when I submitted a bug:

Versions of the packages libpgjava depends on:
ii  libpgsql        6.3.2-12       Shared library for PostgreSQL
ii  jdk1.1          1.1.6v4a-2     JDK 1.1.x (Java Development Kit) - Runtime o
        ^^^ (Provides virtual package jdk1.1-runtime)

What's going on here?  Why does dpkg not realize that jdk1.1 is
providing jdk1.1-runtime?

John Goerzen   Linux, Unix consulting & programming   jgoerzen@complete.org |
Developer, Debian GNU/Linux (Free powerful OS upgrade)       www.debian.org |
Visit the Air Capital Linux Users Group on the web at http://www.aclug.org

Reply to: