[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: egcs-1.1 binary incompatibility

John Lapeyre <lapeyre@physics.Arizona.EDU> wrote:

>On Thu, 10 Sep 1998, James R. Van Zandt wrote:
>jrv>   egcs-1.1 compiled C++ code is not binary compatible with egcs-1.0.x
>jrv>   or gcc-2.8.x due to changes necessary to support thread safe
>jrv>   exception handling.
>	Haven't we been using snapshots of egcs-1.1 for several months, at
>least ? I am not sure I understand all of the issues, but maybe this data
>will help.
>	I just tried to compile a number of examples with the latest g++
>	I link it with libcln.so.0.98, which was compiled with g++
>2.90.29-0.6, and associated libraries...The examples work.

Good, but what symptoms should we be looking for?  Does the problem
only affect programs that use threads?  Is it intermittent?  Do you
get a diagnostic at link time?  At run time?  

We need this kind of information before we decide how to upgrade

				- Jim Van Zandt

Reply to: