[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: smbmount and mount [and spaces in devices]

Tommi Virtanen wrote:

> Package: mount
> Version: 2.7l-4
>         This is a bug. I'm opening a bug report. Credit goes to Jens.
>         [I did bump into this earlier, but I had forgotten it already..;)]
> On Thu, May 28, 1998 at 06:50:29PM +0200, Jens Ritter wrote:
> > I see this strange behaviour of samba:
> > I mount a share from a Windows box (with a space in it):
> > smbmount //tornado\!/"xyz iii" xyz -I foobar
> > (xyz is a directory), I use the data in xyz and umount it.
> >
> > Now mount reports:
> >  //tornado!/xyz on iii type /mnt/xyz/tornado1/xyz (smbfs)
> >                 ^^^^^^^^^
> >   Strange isn´t it?
> [...]
> > Is it a fearture or a bug? If it is the latter one, where to report?
>         Actually, it isn't strange. Status of currently mounted
>         filesystems is saved in /etc/mtab, and this file has one
>         line per mount, fields separated with a _space_. So, if
>         you have a mount point/device with a space, fields are split
>         wrong.

 I had a similar problem with my package `vold' that mounts cdroms under
If the CD has a volume name with a space (not allowed by iso9660---but who cares
`mount' showed up weird things.  I `fixed' this behaviour by a " " -> "_" change
in the mtab entrys.

By the way, mtab entries are read/written by `getmntent' if i remember


David A. van Leeuwen

          Echt stijlvol sterven doe je / bij een ander op de mat
          Op de dag dat je bezorgd wordt / door het NRC Handelsblad

                                                        ---Joop Visser

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: