[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libc6 cutting filenames?

>>>>> Ulf Fredriksson writes:

 > Magosanyi Arpad <mag@bunuel.tii.matav.hu> writes:
>> In our local Linux list someone had reported that KDE forgets the first
>> letter of filenames. Someone else replied that it must be a libc problem,
>> because he have this problem with another package.

 > I have about the same problem... I have an Amiga2000 with an old accelerator
 > board, and have tried to install Linux (both WatchTower and Debian) and have
 > the same problem, the first char is cut of... This can't have anything to do
 > with KDE, but must be a libc problem...

>> Can anyone reproduce or confirm the problem? If yes, is there a known
>> solution? (I guess it is something to do with wrong headers in /usr/include,
>> but not sure.)

 > The problem is there, but I have not been able to figure out where exactly the
 > problem is... I would very much like to know _WHERE_ the problem is, and how
 > to fix it, since I have tried many different boot-/root disks with no avail...
It's the first time I'm hearing this with Linux/glibc. If either of
you could come up with a small test program which shows the bug (try
to figure out what KDE or whatever program shows this behaviour does
to get the filename and print it), it might be possible to fix
it. From your description it looks like an off by one error but I
don't know where.

 Andreas Jaeger   aj@arthur.rhein-neckar.de    jaeger@informatik.uni-kl.de
  for pgp-key finger ajaeger@alma.student.uni-kl.de

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: