[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: autoup.sh & considerations on bail-out scripts

On Fri, 13 Feb 1998, Hamish Moffatt wrote:

> How do you mean wedge in?
> If the script were to upgrade libc5 to 5.4.x, then upgrade dpkg to 1.4.x
> for libc5, it could upgrade systems right back from buzz (debian 1.1).

autoup can upgrade a system from rex to hamm.  i think you were working on
getting it to do buzz as well - did you have any luck with that?

> buzz had dpkg 1.2.x, which doesn't have the --get-selections that
> autoup wants to use. dpkg (from bo) needs libc5 >=

autoup doesn't use --get-selections or --set-selections. it just removes
packages that need to be removed (old libc5 -dev packages etc), and then
installs some new libc6 stuff in the correct (i.e. SAFE) order.

btw, the first thing that autoup installs is the latest libc5 from
hamm's oldlibs/ (it has to, in order to avoid conflicts with libc6)


craig sanders

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: