[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Overlaps between bo and hamm

On Sun, 25 Jan 1998, Oliver Elphick wrote:

> Richard Braakman wrote:
>   >Oliver Elphick wrote:
>   >> Richard Braakman wrote:
>   >>   >I have a list here of package overlaps that may cause problems when
>   >>   >upgrading from bo to hamm. 
>   >> 
>   >>   >Overlap hamm/bible-kjv-text_4.00-5 and bo/bible-kjv_4.00-2:
>   >>   >   usr/lib/bible.data
>   >>   >   usr/lib/bible.data.conc
>   >> 
>   >>   >Overlap hamm/postgresql-dev_6.2.1-9 and bo/postgres95_1.09-1:
>   >>   >   usr/man/man3/catalogs.3.gz
>   >>   >   usr/man/man3/large_objects.3.gz
>   >>   >   usr/man/man3/libpq.3.gz
>   >>   >   usr/man/man5/page.5.gz
>   >> 
>   >> These overlaps are OK because the packages conflict.
>   >
>   >Hmm... postgresql-dev conflicts with postgres95-dev, but not with
>   >postgres95 itself.
> Postgresql-dev requires libpgsql, which conflicts with libpq1 but not with
> postgres95... yes, I agree that it would be better to make the conflicts
> more general.  I will make libpgsql conflict with postgres95 as well.

The method I used with gmp when applied to postgresql would have:

postgresql-dev depend on postgresql and conflict with postgress95-dev
postgresql conflict with postgresql95

It isn't clear that this is the desired result if you wish to allow both
postgresql and postgresql95 to coexist on the same system. In this case
the current conflicts are sufficient for the desired result. (gmp uses the
above described technique to remove gmp in favor of either gmp1 or gmp2
{which don't conflict with each other, either runtime, or development}
without creating undesired conflicts)

>   I don't see bible-kjv-text conflicting with
>   >anything; it should probable Replace older versions of bible-kjv.
> The control file has:
> Package: bible-kjv-text
> Architecture: any
> Depends: ${shlibs:Depends},bible-kjv
> Conflicts: (bible-kjv << 4.00-5)
> but I agree that dselect doesn't report this conflict.  I don't know why not.
I believe this is because dpkg sees conflicts as a dependency and can't
lump the two together. Besides, the proper way to write this is as a
single dependency:

	Depends: ${shlibs:Depends}, bible-kjv >= 4.00-5

This satisfies the depends and the conflicts both in one blow, leaving
dpkg with the number of actions that it can take from this state ... (1).


_-_-_-_-_-_-   Author of "The Debian User's Guide"    _-_-_-_-_-_-_-

aka   Dale Scheetz                   Phone:   1 (904) 656-9769
      Flexible Software              11000 McCrackin Road
      e-mail:  dwarf@polaris.net     Tallahassee, FL  32308

_-_-_-_-_-_- If you don't see what you want, just ask _-_-_-_-_-_-_-

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: