[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: IMPORTANT - Is your libc6 library broken?

Guy Maor writes:
 > This paragraph, from libc6-migration.text.gz is VERY IMPORTANT!
 >    Libraries (regardless of which library they're compiled against) need
 >    to have runtime dependencies on one of libc, libdl or libm to enable
 >    the shared linker to determine which library to use for a binary.
 >    These runtime dependencies are _NOT_ dependencies in the Debian
 >    way, but dependencies generated by the linker when generating the
 >    shared library. See the binutils manual for more information.
 > Any library which does not have a runtime dependency and uses the same
 > soname for libc5 and libc6 versions will make ld.so do the wrong
 > thing.

If I infer well from another mail of yours, these broken shared libs
are those reported as "statically linked" by "ldd" ?

Yann Dirson  <dirson@univ-mlv.fr>        | Stop making M$-Bill richer & richer,
alt-email: <ydirson@a2points.com>        |     support Debian GNU/Linux:
                                         |         more powerful, more stable !
http://www.a2points.com/homepage/3475232 |
		    A computer engineer's looking for a job !

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: