[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: xlib6g/xpm4 fun



On Sat, 13 Sep 1997, Jim Pick wrote:

> I needed to install the xpm libs out of Incoming.  That was quite a challenge.

There was a problem in 3.4j-0.1 with xpm4g conlicting with xpm4.7 and
xpm4 providing xpm4.7 and depending on xpm4g, but that was corrected in
3.4j-0.2, uploaded yesterday. Some problems remain though...
 
> I had to use dpkg --auto-deconfigure to install the new xpm4 package in
> place of the xpm4.7 package - breaking a bunch of packages in the process
> (it conflicted even though xpm4 has a 'Provides: xpm4.7').
> 
> I got the rest of the xpm packages to install (except for xpm-bin, below),
> and fvwm2 compiled cleanly.  (whew)
> 
> The I couldn't configure the packages that broke because they depended on 
> xpm4.7 -- the xpm4 package has a 'Provides: xpm4.7', so I'm
> unsure why this is happening.  Perhaps because the dependencies usually
> include a version number (ie. 'Depends: xpm4.7 (>= 3.4g-0)').

These are the problems I was talking about before... I don't know yet
how to provide a versioned xpm4.7 (I've been told Provides: xpm4.7 (3.4j-0.2)
doesn't work), and versioned dependencies are not fulfilled with 
Provides: xpm4.7

	Suggestions?
-- 
Enrique Zanardi					ezanardi@noah.dfis.ull.es
Dpto. Fisica Fundamental y Experimental
Univ. de La Laguna


--
TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .


Reply to: