[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Uploaded xkeycaps 2.38-2 (source i386) to chiark

On Sep 12, Manoj Srivastava wrote
> J> Yes. Install the xaw3d from stable (with --force-conflicts), put it
> J> in /etc/ld.so.conf before the other xaws, ldconfig and ldd
> J> /usr/X11R6/bin/xkeycaps.real : you'll see it resolves to the xaw3d
> J> libXaw.so.6, which is for libc5.
> Since the user used --force-conflicts, is this not caveat emptor? I can
> make the system go into all kinds of unusable states if I use
> force-conflicts, and it may not be reasonable to expect the aintainers to
> guard against that.

I used --force-conflicts to demonstrate what would happen if a 1.3 user were
to install xkeycaps without xkeycaps having the Conflicts: line it now has:
result: at runtime, a libc5/6 mixture (even though xkeycaps itself is
properly build to be libc6 only).

POPULATION EXPLOSION  Unique in human experience, an event which happened 
yesterday but which everyone swears won't happen until tomorrow.  
- The Hipcrime Vocab by Chad C. Mulligan 

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: