[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFC: library conventions for libc5 and libc6 in hamm Take 4

>   5. Conflicts & Dependencies for hamm packages
>    The hamm libfoo package has to depend on libc6 and has to conflict
>    with libfoo-dev and libc5-dev.

Are you sure here? I'd say you mean this:

    The hamm libfoo package has to depend on libc5 and has to conflict
    with libfoo-dev.

- libfoo is libc5, so it should depend on libc5.
- Yes, we should try and get rid of libc5-dev, but I'm not sure it's
  the job of random libries to force users to do that: as far as
  I can see, nothing breaks when the two are installed together.

>   6. Handling bugfixes for Debian 1.3 (bo)
>    ii) Any bo package for libfoo _has_ to conflict with libc6,
>        libfoo-altdev and libfoog. 

That's a bit late now. Maybe you mean "any newly uploaded bo libfoo package".
(we'd get a flood of bo bugs otherwise, against all bo libraries).

>    iii)The libfoo-dev package has to conflict with libc5-altdev and
>        has to depend on libc5-dev.

Again, better change that to "any newly uploaded libfoo-dev package".
And, the "conflict with libc5-altdev" seems redundant, as libc5-altdev
already conflicts with libc5-dev. And all old (bo) libcfoo-dev packages
should depend on libc5-dev anyway.

>  [2] The location ../libc5-compat was introduced in the ldso package. As
>      ldso is a package on all linus distributions we'll keep it for


joost witteveen, joostje@debian.org
#!/usr/bin/perl -sp0777i<X+d*lMLa^*lN%0]dsXx++lMlN/dsM0<j]dsj
$/=unpack('H*',$_);$_=`echo 16dio\U$k"SK$/SM$n\EsN0p[lN*1
#what's this? see http://www.dcs.ex.ac.uk/~aba/rsa/

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: