[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFC: library conventions for libc5 and libc6 in hamm Take 4

joost@rulcmc.leidenuniv.nl (joost witteveen) writes:

> >   5. Conflicts & Dependencies for hamm packages
> > 
> [..]
> > 
> >    The hamm libfoo package has to depend on libc6 and has to conflict
> >    with libfoo-dev and libc5-dev.
> Are you sure here? I'd say you mean this:
>     The hamm libfoo package has to depend on libc5 and has to conflict
>     with libfoo-dev.
> - libfoo is libc5, so it should depend on libc5.
> - Yes, we should try and get rid of libc5-dev, but I'm not sure it's
>   the job of random libries to force users to do that: as far as
>   I can see, nothing breaks when the two are installed together.
OK I will change the libc6 dependecy.
However we must not have any -dev package in hamm that is a
libc5-based package, i.e. libc5-dev may not be installed on a hamm
system. It will break lots of stuff.


Helmut Geyer                                Helmut.Geyer@iwr.uni-heidelberg.de
public PGP key available :           finger geyer@saturn.iwr.uni-heidelberg.de

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: