[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

kinda a bug with Debian 1.3 installation


I found a small bug with installation of 1.3.0 last night while
installing on a friend's Toshiba Tecra Laptop.

The problem deals with the kernel/pcmcia services.

He has a Panasonic pcmcia 4x CDROM.  It is supported by pcmcia and I
have had it working in linux before so I didnt expect any problems.
We intended to install the base system from floppies, copy the
pcmcia-cs and pcmcia-modules to another floppy and then install them
with dpkg by hand before continuing the installation from CD.

This worked for 1.2 (I think).

The problem is that boot disks are kernel 2.0.29.  pcmcia-cs installs
fine with this, and there are 2 versions of pcmcia-modules (one for
2.0.29 and one for 2.0.30).  The problem is that the
pcmcia-modules-2.0.29 depends on an earlier version of pcmcia-cs that
isnt present.  It wont install without --force-depends.  Even when we
tried this the modules in pcmcia-modules-2.0.29 do not work.  They
give a long list of missing kernel symbols when you boot.

So.  We needed kernel 2.0.30.  It's on the CD, but we can't read it
from linux.  We had to reboot to DOS and copy it to his dos partition
(too big for a floppy).  After rebooting the base linux and mounting
his dos partition, installing kernel-image-2.0.30 went fine until we
tried to reboot.  Remeber he has a tecra.  We couldnt reboot with LILO
or a boot floppy cause kernel-image has a bzimage in it.  So I copied
the kernel image back to dos and booted with loadlin.  That worked
fine.  Now installing pcmcia-modules-2.0.30 and pcmcia-cs worked
without problems.  Rebooting (via loadlin) worked again.  Now we have
access to the CD.  We install kernel-package and
kernel-source-2.0.30, and compiled a zimage kernel for his tecra.  now
we can boot 2.0.30 with lilo or a floppy and not use DOS.

Now we can continue with dselect.

Really this was only about an hour or so.  Not that big a deal for me
(an experienced Linux/Debian user/admin), but there is now way he
could have done it alone (or other newbies I'd imagine).

I think the root of the problem was that the boot floppies have 2.0.29
on them and they dont match the kernel support services in the
distribution.  Of course, I dont know the whole story so maybe there
is a reason to need 2.0.29 on boot floppies while we have 2.0.30 in
the distribution.  Another way to get around this problem would have
been to include pcmcia-modules-2.0.29 that work.  

Finally, my last bit of advice is to include some documentation (maybe
next to the tecra boot floppies on the ftp site) explaining how tecra
kernels are different.  It took me a while on the web to realize that
I needed to compile a zimage and not a bzimage.  It might make things
easier for newbies who want to compile a new kernel to know they need
to add -zimage to make-kpg

I haven't filed a bug report, basically, because I'm not sure which
package to file against.


- --
	  PGP Public Key: finger walter@fozzie.chem.wisc.edu
  PGP Fingerprint: A5 AB 25 7D 7A FD 4D FE  BE 21 47 60 0C DC 67 9E
 ----==-- _                     / /  \         
 ---==---(_)__  __ ____  __    / / /\ \	              - edwalter@iname.com
 --==---/ / _ \/ // /\ \/ /   / /_/\ \ \            - walter@chem.wisc.edu   
 -=====/_/_//_/\_,_/ /_/\_\  /______\ \ \     - edwalter@students.wisc.edu

Version: 2.6.3
Charset: noconv


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: