[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Questions (Debian Install) (fwd)

Can someone please try and answer this guy? I afraid I can't do it
my self.

---------- Forwarded message ----------
Date: Fri, 23 May 1997 08:57:30 -0700
From: David Cary <cary@agora.rdrop.com>
To: "Boris D. Beletsky" <borik@isracom.co.il>
Subject: Questions (Debian Install)

Thanks again for your work on Debian.

I started all over Yet Again, and I think I discovered a bug in my "latex"
distribution that crashed the default setup (but I have documented a way to
work around it).

I told you before that I discovered the default Debian setup takes over 100
MB -- well, I was wrong. When I disable "latex" (didn't work anyway), the
default Debian setup only takes about 77 MB of hard drive.

>You can ask for my advice, I will be glad to help.


I've appended my new installation journal below.

Jump to the end and answer that last question. I keep thinking I'm missing
something simple when I read "man ls".

Any other questions you answer will be bonus.
(I'm thinking about posting this to comp.os.linux.setup, to get answers to
questions that you miss).

It took me a long time to discover the version of X I have doesn't work
with my video card. I can't help thinking that it should have been more
obvious, taken me less time.

<wishful thinking>
Ideally it would have been nice if, when setting up the X Windows package,
it had read the card information from the video card, looked it up in a
simple text database of supported cards, and printed the appropriate
message --
"I think I found a **** card -- good",
"I think I found a **** card, this is *not* supported because the
manufacturer insists on a NDA",
or -- in my case --
"I think I found a Trident GUI 9440AGi, we're not quite done with the
drivers for this -- check http://***/***/*** to see if that version has
</wishful thinking>

David's Debian Journal
"be sure to visit ... http://www.debian.org";

If I peek under the fan/heatsink off my CPU, it says:
3.45 Volt
Designed for Microsoft(r) Windows(R)95

bought the "Winter 1997 Linux Internet Archives"
(seeing as how it's only May 1997 here....)
from Powell's for $24.85 -- that's only ($24.85/8 CDs) = $3.11/CD -- what a
deal !

A little confusion:
the package talks about "The Slackware Derivative" and "the populare
Slackware distribution are on CD-ROM 5." and "the /slackware directory",
but on the CD-ROM labeled "Disc 5: Linux Internet Archives: Winter1997"
there is only one directory in the root, named /debian.

First, I made sure I had a proper "DOS 4" boot disk that will let me access
my CD-ROM drive and included FDISK.exe and FORMAT.COM and edit.com. (I
created this with Windows95:Start:Settings :ControlPanel:Add/RemovePrograms
:SetupDisk :CreateDisk. One that "startup disk" was created, I ran Setup
program that that came with my CD-ROM hardware to allow that startup disk
to access the CD-ROM).

Made sure I had taken everything off the hard drive and put somewhere else
(backed up).

After a lot of false trails (goose chases), I followed the
(by Bruce Perens)

[The "Debian" installation is far superior to the "Slackware" installation.
I don't know anything about "Red Hat"]

I stuck in my boot floppy,
Powered up my machine, pressed 'DEL' at the appropriate time.
Stuck in "Disc 5";

and check my BIOS settings one more time.

They look OK;
install.html mentions
Extended vs. Expanded Memory

If your system provides both extended and expanded memory, set it so
that there is as much extended and as little expanded memory as
possible. Linux requires extended memory and can not use expanded
which doesn't make sense to me -- I thought that these options were set up
via "config.sys" in DOS, *not* the BIOS. (Since Linux doesn't have
"config.sys", I hope it Does the Right Thing).

Advanced Power Management

If your motherboard provides Advanced Power Management (APM), configure
it so that power management is controlled by APM. Disable the doze,
standby, suspend, nap, and sleep modes,

I turn APM totally off, because last time:
When I enable APM, "doze" cannot be disabled, but only delayed by 512
minutes. So I enabled APM, set Doze to "8 Min" (arbitrary value), and
disabled the others.
I press [enter] at the boot prompt;
Whoopsies. I get a "APM BIOS ... Unable to handle kernel NULL pointer
dereference at virtual address c00004e0" message (with lots more

I "save CMOS changes and exist", and boot my DOS startup disk.

Most people have a "C:" hard drive and a "D:" CD-ROM drive; or a "C:" and
"D:" hard drive, and a "E:" CD-ROM drive.
However, my oddball autoexec.bat sets up my CD-ROM as drive "F:".

set my %PATH% to "f:\debian\tools":
  set PATH=f:\debian\tools;
went to
  cd: f:\debian\buzz\disks-I3\1996_6_1

Continuing to follow the directions in
, I mark 6 disks with the suggested labels, then fed them in at the
appropriate time as I ran

 rawrite2 -f boot1440.bin -d a:
 rawrite2 -f root.bin -d a:
 rawrite2 -f base14-1.bin -d a:
 rawrite2 -f base14-2.bin -d a:
 rawrite2 -f base14-3.bin -d a:

Then I put the "Installation Boot" disk back in the drive and rebooted.

"This boot floppy installs the Linux kernel version 2.0.0."

I press [enter] at the boot prompt;

Lots of messages scroll by (I really like the <shift><PageUp> scrollback
"Calibrating ... 66.56 BogoMIPs"
"APM BIOS not found."

"This root floppy was built on June 16, 1996."
I follow the directions:
"Insert root floppy disk"
and press enter ...
I pick a color display;
press enter twice...

I pick "A: Partition a Hard Disk"
(I happen to have a 814 MB HDD, but I want a dual-OS system ...)

I psych myself up, convince myself that I really have backed up everything,
and then delete all the old partitions.

side note:
When I gave Linux a 100 MB partition, and installed the default selections
in the Debian distribution; when I tried that earlier I got
  Setting up latex (2e-7) ...
  Building new latex format(s) using install-fmt-base(8)
  Rebuilding 'latex' format ...
seems to take a *long* time.

It hung up for over 30 minutes (!), so I hit control-C which killed it,
returning me to the 'dselect' menu.
I go to select, and try to turn off latex ...
'dselect' unexpectedly dies, giving a "No space left on device" error and
leaving me at the # prompt.

I know I gave Debian Linux a 100 MB partition;
says ... yep, 98 MB used (I assume the other 2 MB are inodes and misc).

When I started all over, gave Linux a 200 MB partition, and installed the
default selections in the Debian distribution, I got
  Setting up latex (2e-7) ...
  Building new latex format(s) using install-fmt-base(8)
"Rebuilding 'latex' format ..." churns my HDD for a while (between 2 and 3
minutes), then the HDD stops.
Well, it's been a solid 10 minutes. I think it's hung. Grr.
so I hit control-C which kills it.
*now* I get a "No space left on device" message;
I delete a few things, then check
  # du
now tells me that I have 195937 KB of stuff on "/", out of the 200 MB partition.
I begin to suspect that "latex" configuration has a bug in it that always
fills the hard drive (this is *exactly* the problem I had with a 100 MB
I suspect the "latex" configuration has a bug that will fill the entire
hard drive no matter how much space I give it.

This time I'm going to stick with 200 MB, but avoid "latex" entirely.

I tell it to create a 200 MB primary partition for Linux (Hm, it got
rounded off to 199.83), a 500 MB primary partition for That Other OS (it
got rounded off to 500.07 MB), a 65 MB logical partion for Linux Swap (got
rounded to 64.97),
leaving 49.22 MB of leftovers.

I set the "Bootable" flag on the Linux partition for no good reason.

Then I [W]rite these settings to disk and [q]uit "cfdisk".

I hit return to continue with
"Next: Initialize and Activate the swap partition".
with /dev/hda5.
and hit return a bunch of times.

I hit return to continue with
"Next: Initialize a Linux Disk Partition"
with /dev/hda1
and hit return a few times to take the defaults.

I hit return to continue with
"Next: Install the Base System".

and pick /dev/fd0
to use my "first" (and only) floppy drive (a 3.5" floppy drive).

I follow the on-screen directions; feeding in the 3 disks I created earlier.

I continue with
"Next: Install the Operating System Kernel"
and stick in the "Debian Linux Boot Disk" (again).

"Next: Configure Device Driver Modules"
One might think I'd ned to pick "cdrom" or some other driver, but I happen
to know that I don't need any of this right now -- I just hit return to
choose "Exit: Finished with Modules".

"Next: Configure the Base System"
I take the default "U.S.Keyboard".
I choose the "US", "Pacific" timezone.
I am tempted to choose GMT ... but I also want to run other OSes, so I say
  Is your system clock set to GMT ... ? n

"Next: Configure the Network"
I choose a host name of "DataExpress", and tell it I'm not on a network.

"Next: Make Linux Bootable Directly from the Hard Disk"
"Install a master boot record on /dev/hda ?" Yes.
"Boot the Debian system on /dev/hda1 as the default ?" No.

"Next: Make a boot floppy"
I stick in a blank floppy labeled "Debian Custom Boot" and hit return.
After it's finished writing, I pull it out and write protect it.

"Next: Reboot the System"
I hit return.
Strange messages appear, then the system reboots.
I get a LILO message..... lots of things scroll by....

"Changing password for root
Enter new password :"
I pick a good one.

"Enter a username for your account:" cary
and I type in my "finger" information.

The Debian setup now tells me
"I'm now going to start the 'dselect' program."
I hit return and continue to follow the directions.

I pick cdrom
and tell it "/dev/hdb" for my IDE CD-ROM drive.
It automatically finds the "/debian" directory, so I hit return to accept
it's defaults.

I enter "none" for 2 directories apparently missing from the CD-ROM. I
understand why "non-free/" is missing; why is "local/binary/" missing ? Ah
well, I think I can always download it later.

I press return a few more times.

I'm pretty sure the "latex" package is hosed on my CD-ROM, so I search for
it with "/latex" and press "_" to purge it.
It finds a dependency conflict, but I allow it to automatically resolve it
(it chooses to also purge "texbin") by pressing return.
I press return again ... it finds more dependency conflicts; I choose to
purge all the "latex"-related ones (kpathsea, texbin, latex, mfbin,
mfbasfnt) by arrowing to them and pressing "_".
I allow it to automatically resolve the others (it chooses to *not* install
"cpp", but install "gcc" instead) by pressing enter.

Other than "purging" the "latex"-related stuff, I allow it to install the
default set of packages.

The CD-ROM and HDD spin for a long time;
lots of messages about "skipping deselected package" and "Unpacking", etc.
scroll by.

It whines about
"More than one copy of package libc5 has been unpacked in this run ! Only
configuring it once"
3 times.
and similar messages about "package modules", "package strace".

It asks about "etc/group/";

It asks about "etc/group/";
I hit return to take the default "No, keep current version".
"Setting up Perl ...
h2ph has always been somewhat broken"

"Setting up ppp ...
shift: shift count must be <= $#"
"Setting up inewsinn ..."
I hit return to take all the defaults, including
"Organization [A poorly-maintained Debian GNU/Linux InterNetNews site]:"

Whoa, a ugly multi-colored full-screen text window pops up.
"Debian-Tex installation"
I thought I told it to kill all the "TeX" stuff.
Now what do I do ?
I turn off all the languages except "english" (what is "british ?) and hit
return to continue.

things keep installing
  Would you like to use english for the default dictionary [y/N]: y
"Setting up cron ..."
"Setting up smail".
I dunno -- I was planning on using my modem to connect to my ISP via PPP,
and that doesn't seem to be any of the options. I guess I should choose
"(5) No configuration.... your mail system will be broken and should not be
used. ... You must... later ... run /usr/sbin/smailconfig ...".
Lots more "setting up" messages
"setting up elm": I hit return to take all the defaults.
I hit return to make the "american" dictionary the default.
"Setting up elm ..."
I hit return to take all the defaults;
"Installation OK. Hit RETURN."
I do so.

I get back to the "dselect" main menu, and I hit return to continue with
"4. [C]onfig"
Doesn't seem to do anything; the screen blinks and then I return to
"dselect" main menu with the cursor on
"5. [R]emove"
Sure, why not.
Screen blinks again; now I'm at
"6. [Q]uit." I hit return again.

I see a big paragraph of text
"You may now login as 'root' ... To create a normal
user account, you should run 'adduser' as root ...
..... for example .... "adduser imurdock".
multi-tasking ... <Left Alt><Fn> ...
Have fun!
Debian Linux 1.1"

I login as "cary".
Hm, seems to work.

"man" works fine.

I look arount a little (with "cd" and "less" and "man").

I logoff with "exit".


What is the proper way to shut down ? I've been logging out all active
shells, then hitting ctrl-alt-delete.

I turned the power back on, logged in as "root", went to root ("cd /"),
and ran "du" to check disk usage.
It lists all the directories...
The total at the bottom is "76716" (KBytes, I assume).
There's one little bit of weirdness; one line says
"du: ./proc/129/fd/4: No such file or directory".

zless /usr/doc/HOWTO/INFO-SHEET.gz
has some interesting things to say.


Now, how do I get X Windows running ?

I run "dselect" (logged in as "root", of course), and pick Xcoral (a
package I know requires XWindows).

Hm. "dselect" claimed it installed and configured Xcoral without any problems.
Yes, but how to run it ?

I run "dselect" and choose "xbase". I accept the other couple of packages
"dselect" thinks it should install with "xbase".
...... it churns installing ...
"We recommend the use of 'xdm' "[to start X windows].
I hit return to scroll through the pages of video cards ...
..... and finally pick "142  Trident 8900/9000 (generic)"
"Running X -probeonly -pn -xf86config /tmp/XF86Config.tmp.
X -probeonly call failed.
No Clocks line inserted."
For further configuration, refer to /usr/X11R6/lib/X11/doc/README.Config."
Ah, I think I need to install some sort of "mouse driver" *before* trying
to get X Windows to work.
Hm, searching through "dselect" with "/mous" doesn't seem to find anything.

I pulled my video card. It says:
large fine-pitch square chip:
(c)Trident '94"
DIP in socket:
"Trident Ver. A5.4"
2 surface-mount dips:
2 empty sockets.

The "Windows Drivers" disk that came with that card
claims to be a
"Trident TGUI9440AGi"

( /usr/X11R6/bin/SuperProbe )
SuperProbe reports:
First Video: Super-VGA
Chipset: Trident GUI 9440AGi
Memory: 1024 KB
RAMDAC: Sierra SC1148{2,3,4} 15-bit or SC1148{5,7,9} 15/16 bit HiColor
(with 6-bit wide lookup tables (or in 6-bit mode))

zless /usr/doc/HOWTO/XFree86-HOWTO
seems to have some useful stuff.
It recommends reading
less /usr/X11R6/lib/X11/doc/README.Config
, the XFree86 configuration tutorial.

less /usr/X11R6/lib/X11/doc/README.trident
specifically states
"The TGUI9440 ... (and later) chipsets are NOT supported by this release of
the SVGA server. We are working ... they should be supported in the next

Well. I guess I should download the latest release and see if *it* will
work with my board.

Hm; I thought there was some way I could ask Linux where on my hard drive
the minicom program was; something like
  ls -R minic*
but that doesn't work ....
What is the *nix way to "Find file with name:___" ? I know how to do this
with the Mac OS and several different Microsoft OSes, it's kinda annoying
me that I can't do this with Linux.

David Cary "mailto:d.cary@ieee.org"; "http://www.rdrop.com/~cary";
Future Tech, Unknowns, PCMCIA, digital hologram, <*> O-

Boris D. Beletsky		           borik@debian.org
Network Administrator			borik@cs.huji.ac.il
Institute of Computer Science,          borik@isracom.co.il
Hebrew University 		       Home: +972 2 6411880
Jerusalem Israel                       Work: +972 2 6585690
		 O skol'ko nam otkrytiy chudnyh
		 prenosit microsofta duh!
		 I Intel, syn oshybok trudnyh
		 I Borland, paradoksov drug.

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: