[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

strange behavior with getty on Debian/SPARC



Dear developers,

  I'm working on Debian port to SPARC but I have some troubles with getty.
I'm using dupload to upload packages to Debian/SPARC distribution on master
but this program shows a strange behavior.
In fact, when it request for my password to enter, I should type in characters
by multiple of 4.  I have extracted a small script shell that breaks in my
system:

#!/bin/sh
stty -echo cbreak
echo -n "Password: "
read pw
echo
stty echo -cbreak

When I run it, it prompts:
  stty: standard input: unable to perform all requested operations
for the first stty instruction.  Then "read pw" accepts characters and doesn't
show them but doesn't return immediatly after I typed in the enter key
excepted when I entered exactly a multiple of 4 characters (enter key
included).  So I should type in some other characters to be able to continue :-((

I experienced this behavior in standard getty (release <= 1.40a from loginutils
1.0-5) and rlogin to my Sparc through xterm (from Xfree86-3.2 on my i386 box,
or MIT-X11R5 from a Sun Sparc under SunOS-4.1.3).

Moreover, I installed gettyps-2.0.7i-1 then "stty cbreak" do the right thing
on linux consoles after I have replaced the old tty entries of /etc/inittab by
the new ones:
<n>:2345:respawn:/sbin/gettyps tty<n> VC linux

It seems there's a bug in loginutils/getty & xterm.  Or maybe it's a bug in
the tty/pty driver?
I run kernel 2.0.29-970215 snapshot for Sparc if it can help.

This strange behavior only appears on my Debian/SPARC system however. Not on
standard Debian/i386.

I'd appreciate any help.
Bye.

-- 
 Eric Delaunay                 | "La guerre justifie l'existence des militaires.
 delaunay@lix.polytechnique.fr | En les supprimant." Henri Jeanson (1900-1970)


--
TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-sparc-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .


Reply to: