[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: architecture specific upload announcements

> I've been following this for awile and I haven't seen anyone deal with the
> problem of versioning! Right now we cannot tell what compilers and
> libraries a package needs to be able to compile. You could install
> everything on the build machines but that causes instant problems when a
> package needs 1.2 of a library but 1.4 is installed and they are
> incompatible. 

Maybe debmake's file /usr/doc/package/buildinfo.debian could give some
hints in that respect? It includes the versions of the most important
tools the package was built with.

Reply to: