[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems with 1996-11-28 disk set

Thought I might try out the new Install Disks on a new HP NetServer
5/133 LC (P133, 32MB, SCSI 4GB, SCSI CD, SCSI DAT).

First, the rescue disk wouldn't boot.  After a heroic effort to find
cd-rom drives, and right after resetting the SCSI bus on the
AIC-7770-TWIN SCSI controller, it failed with:

	aic7xxx: Downloading sequencer code...done.
	aic7xxx: Resetting the SCSI bus...done.
	NCR53c406a: no available ports found
	aic7xxx: (aic7xxx_isr) Encounter spurious interrupt.
	scsi0: BRKADRINT error(0x1):
	  Illegal Host Access
	Kernel panic: scsi0: BRKADRINT, error 0x1, seqaddr 0x0

This was not surprising -- the NetServer LC is an odd EISA/PCI hybrid
with a lot of proprietary features, and I didn't expect this to be
easy.  It took hours of time and a call to HP Support earlier today to
disable sector translation on the SCSI controller -- we didn't know it
doesn't have a BIOS hot-key, and is therefore configurable only by
the CD-ROM that came with it.

At any rate, I figured our custom-tuned 2.0.27 might work, so I copied
this in place of /linux on a new rescue floppy and rdev'd it to

To my surprise, this worked perfectly.  (Though it was compiled in,
I've never used initrd before.)  Everything was cool until it was time
to Partition a Hard Disk.

At that point, cfdisk messed up the partition table, correctly writing
only the first nine partitions (around 2 GB) of a 4.036 GB disk.
Subsequent attempts to run it produced "FATAL ERROR: Cannot seek on
disk drive."

Luckily, I knew the text-based fdisk was there, so I dropped to a
shell and used it to complete the partitioning.  Even if cfdisk worked
perfectly, I think it would be nice if fdisk was a sub-menu option,
for those who are more familiar with it.

Installation of the Base System and of the Operating System Kernel
went smoothly.  The date on the disks said November 27, not 28, but
they worked anyway.

Something Went Wrong during installation of the Device Drivers because
the my hacked rescue disk had a 2.0.27 kernel on it -- "Can't open
/lib/modules/2.0.27/modules.dep: no such file or directory."

Because of this, Install Device Drivers did nothing.  I wasn't worried
though because all the drivers I really need are already compiled into
the custom kernel.

Configuration of the Base System and of the Network went smoothly, as
did Make Linux Bootable Directly from Hard Disk.  I skipped Make Boot
Disk -- I already have plenty.  :-)

So LILO booted the system, and I found a few oddities.  First, there
was an apparently unimportant problem during boot:

	Cleaning up /tmp /var/lock /var/run ... done
	cannot open file N
	Cannot open font file N
	run-parts: /etc/rc.boot/0kbd exited with return code 1

Second, from prior experience, I had expected it to ask me to set up
passwords for root and for myself, and to then start up dselect.
Instead it simply went into an infinite loop of root logins on tty0.
I have to wonder if beginners would know what to do next here
(actually, the documentation could be perfectly clear on this -- As a
handicap, I haven't read it.  :-)

That's where the system stands as I leave tonight.  Tomorrow I get to
install nearly all of bo from our mirror....
  mm   mm     Johnie Ingram, Network Technician
   mm mm      Research & Development, The Library Network
   m m m      33030 Van Born Road, Wayne, MI 48141  +1 313 326 8910 x144
  mm   mm    
  GO BLUE     PGP  E4 70 6E 59 80 6A F5 78  63 32 BC FB 7A 08 53 4C 
  "Ibala lami elimnyama, ndiya zidla ngalo...."
		-- One by One  (Disney's Rhythm of the Pridelands)

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: