[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: newest ncurses

Michael Alan Dorman writes ("Re: newest ncurses"):
> On Sun, 10 Dec 1995, Michael Alan Dorman wrote:
> > I'm now uploading ncurses-1.9.8a-2 & co.  It is also available for ftp
> > from lot49.med.miami.edu:/pub/linux/ until it gets cleared at
> > ftp.debian.org.
> I forgot to mention that you will almost certainly have to use 'dpkg 
> --purge --force-depends' on both ncurses-runtime and -developer, since 
> the new packages now (correctly) conflict with the above, and some base 
> packages depend on ncurses-runtime.

If you use dselect (or dpkg --remove without --force-depends) to
deselect the old packages, dpkg will automatically remove them when
the conflicting ones are installed (if they have the right Provides

> This may break those particular programs, since we have changed the 
> search structure for terminfo entries in the new packages.  You can 
> correct this by symlinking the entries under /etc/terminfo to 
> /usr/lib/terminfo.

Is it just me, or should that be /lib/terminfo ?  I know that termcap
used to be in /etc, but I think we're agreed that that (like most of
termcap) was an aberration.

terminfo doesn't contain configuration files, so I don't think it
belongs in /etc.


Reply to: