[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Please allow desktop-base 5.0.2 in lenny


could you please allow desktop-base 5.0.2 in lenny?

The change are:

desktop-base (5.0.2) unstable; urgency=low

  * moreblue-orbit-wallpaper-widescreen.svg updated, fix a “transparent”
    horizontal line on top.
  * debian/rules:
    - install splashy themes in /usr/share instead of /etc.     closes:
  * debian/postinst, debian/prerm
    - move properly /etc/splashy/ conffiles to /usr/share/splashy.

 -- Yves-Alexis Perez <corsac@debian.org>  Fri, 24 Oct 2008 00:23:57 +0200

The svg change is in the diff but harmless.

The theme change fixes a naughty bug. Splashy themes were once installed
in /etc/splashy/themes, so desktop-base installed its theme there. But
splashy moved the theme folder to /usr/share/splashy/themes were it
belongs, but replacing /etc/splashy/themes by a symlink, thus breaking
desktop-base. The situation is currently broken in testing.

This upload aims to fix the problem by moving the themes to
/usr/share/themes. I tried to keep conffiles a user could have made, but
after a second thought it may not be a good idea. I don't think anyone
would have made a change there, but if someone has, it'll store a
.dpkg-new file in /etc/splashy/themes, thus preventing the remove (and
replace by the symlink). 

Maybe I should just move those files and lose any user-made modification?
Or should I let an user with modifications in those files do the correct
stuff to fix the problem? (if there is).

What's the RT preference wrt. this issue?


Reply to: