[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#585796: #585796: local-debbugs: Cannot search

On Sun, 08 Aug 2010, Jonathan Nieder wrote:

> Don Armstrong wrote:
> >    * Various changes to make debbugs-local work better (Closes: #585796)
> That does help a lot.
> Now I’ve tried:
> 	echo src:git >~/.debbugs/bugs_to_get
> 	local-debbugs -M
> 	local-debbugs --daemon --no-detach
> and in another VT:
> 	w3m http://localhost:8080/542709
> The resulting output from the daemon:
> 	configuration file '/etc/debbugs/config' doesn't exist; skipping itUnable to locate template /usr/share/debbugs/templates/en_US/cgi/no_such_bug.tmpl
> 	Unable to find template cgi/no_such_bug with language en_US at /usr/share/perl5/Debbugs/Text.pm line 154.
> If I instead try
> 	local-debbugs --show 542709
> then I still get “error reading from socket” from the browser, but this way
> there is no new output from the local-debbugs daemon.
> Will investigate more.  Thanks.

Yeah; the problem is that I've been kind of naïve, and have been
testing this on a system which also has a fully working debbugs
install, so I missed this whole class of problem. I'm going to be
testing it on the plane, and possibly by the time you read this
message I will have a patch which works, and will upload a new

Don Armstrong

"There are two major products that come out of Berkeley: LSD and UNIX.
We don't believe this to be a coincidence."
 -- Jeremy S. Anderson

http://www.donarmstrong.com              http://rzlab.ucr.edu

Reply to: