[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cinnamon 4.8 in experimental

Hi Fabio,

(btw, are you on IRC in the #debian-cinnamon channel?)

> Yes also a short usage.

Great, thanks a lot!

> wait for unstable, I saw many archs that is failed with experimental,

Really? I mean, maybe non-release archs, but as far as I see under the
release archs, there are only three failing cases:
- cinnamon on i386
- cinnamon on mips64el
- cinnamon-settings-daemon on s390x

* Concerning cinnamon on i386: this is something I need to investigate,
very strange error ...

* Concerning cinnamon on mips64el
../src/cinnamon-global-private.h:23:10: fatal error: cinnamon-enum-types.h: No such file or directory
   23 | #include "cinnamon-enum-types.h"
      |          ^~~~~~~~~~~~~~~~~~~~~~~
very strange again.

* Concernin cinnamon-settings-daemon on s390x
Trying a default CMake fallback at cmake
Did not find CMake 'cmake'
Found CMake: NO
No CMake binary for machine 0 not found. Giving up.
Run-time dependency xorg-wacom found: NO (tried pkgconfig)

../meson.build:79:0: ERROR: Dependency "xorg-wacom" not found, tried pkgconfig

So I guess wacom is not available on s390, and we need to disable it

> from upstream cinnamon I saw some fixes for meson build (too recently
> merged and too few tests), for example
> https://github.com/linuxmint/cinnamon/commit/e9f35d270fab316ebc028f396f6c8a8f51de53c3
> that fixes build without network manager (and don't seems optional (add
> nm if found) like before meson so a conditional switch should be added
> in debian/rules for archs without nm)

Arrggg, again NM.
But which **release** archs don't have NM? Cinnamon builds only fail on
i386 and mips64el (see above), both of which are strange but don't seem
to be related to NM.

All the best


PREINING Norbert                              https://www.preining.info
Accelia Inc. + IFMGA ProGuide + TU Wien + JAIST + TeX Live + Debian Dev
GPG: 0x860CDC13   fp: F7D8 A928 26E3 16A1 9FA0 ACF0 6CAC A448 860C DC13

Reply to: