[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Some questions about Kapps and apt

On Tue, 27 Feb 2001 19:52:22 +0800
ha shao <hashao@chinese.com> wrote:

> On Tue, Feb 27, 2001 at 06:57:27PM +0800, phinex@hpcc.ee.nthu.edu.tw wrote:
> > 	我習慣每隔一陣子用 apt-get update; apt-get upgrade
> > 	來檢察 unstable 裡面有沒有更新套件...不過..
> > 	我實在不清處用 apt-get upgrade 後...系統預設會檢察那些
> > 	packages 來升級?因為有些 package 似乎有問題..導致用 
> > 	apt-get upgrade 都會失敗..(好像是 .deb 檔有問題..因為我直接
> > 	用 dpkg -i 安裝也不行...)
> /var/lib/dpkg/status
> dpkg in unstable had a bug that will break installation of certain
> packages under Chinese locale (at least under zh_CN.GB2312). If it is
> the bug you see, set your LC_CTYPE to none "export LC_CTYPE=" and try
> again. If still won't work, I don't know then.
The Error Messages still remain after I unset the LC_CTYPE;


Preparing to replace console-tools 1:0.2.3-17 (using .../console-tools_1%3a0.2.3-17.1_i386.deb) ...
Unpacking replacement console-tools ...
dpkg: error processing /var/cache/apt/archives/console-tools_1%3a0.2.3-17.1_i386.deb (--unpack):
 failed to realloc for variable buffer: 無法分配記憶體
E: Sub-process /usr/bin/dpkg received a segmentation fault.
millennium:/etc# dpkg-deb: subprocess paste killed by signal (中斷的 pipe)


Also, I use the "dpkg --set-selections" to hold the console-tools package.
I may sure that I really have done it (by using "dpkg --get-selections" ),
but the package (console-tools) still appears in the list when I type 
"apt-get upgrade". Have I make some mistakes?

Thank you for your help.

Sheng-Kai Hung          UIN: 10497781
E-mail: phinex@hpcc.ee.nthu.edu.tw
恨情歌工作坊: telnet://hls.twbbs.org
Dept. of Electrical Engineering, National Tsing Hua University

Reply to: