[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ia64_iso


> >It will not boot on any machine.

This might be due to a problem in the ISO image or due to a mismatch of
boot record format and firmware of the machine.

I see that the image is equipped with an El Torito boot record.
The boot catalog begins at block 587 and bears 0 as Platform Id.
This means that it is for "80x86" (in contrast to "PowerPC", "Mac",
or "EFI".)

Whether the BIOS (or whatever boots) of Itanium machines feels
addressed by "80x86" is out of my knowledge.

> >[...]
> >I have tried to burn the iso image on three different machines, and
> >with three different types of cd burning software.  When the image
> >has been burned, and the burning software verifies the files between
> >the source (your file that I have downloaded:
> > [...] 
> >the dialog window states that there is an error between the two files.
> > [...]

This is a strange observation.
It is hard to believe that the content of an image file would cause
a misburn.

Can you try this with a Linux, FreeBSD or Solaris system and one of my
burn programs ? If it does not work, then we could inspect the burn
procedure down to SCSI commands and drive replies.

I tried this on a system with Linux kernel. Medium was CD-RW:

  xorriso -as cdrecord \
          -v dev=/dev/sr0 blank=as_needed padsize=0 -eject \

I then re-loaded the drive tray and did:

  diff debian-6.0.4-ia64-netinst.iso /dev/sr0

which ended without any message, i.e. no difference was found.

(The unload-load cycle of the drive tray is necessary because the
 kernel must clean its cache and learn the new readable size.)

Other media types may have a fuzzy end-of-data. In that case you will
have to help the computer to find the appropriate end of comparison:

  dd if=/dev/sr0 bs=2048 count=122859 | \
  diff debian-6.0.4-ia64-netinst.iso -

The number 122859 was computed from the size 251615232 of the .iso file
divided by the block size 2048.
This should only report messages from program "dd". Like:

  122859+0 records in
  122859+0 records out
  251615232 bytes (252 MB) copied, 74.884 s, 3.4 MB/s

but not complaints from "diff". Like:
  Files debian-6.0.4-ia64-netinst.iso and - differ

If there is the suspicion that media errors are involved, try
  xorriso -indev /dev/sr0 -check_media --

It should report any medium error that is indicated by the drive.
A good run ends like this:
  xorriso : UPDATE : 122859 blocks read in 75 seconds = 22.0xC
  Media checks :        lba ,       size , quality
  Media region :          0 ,     122859 , + good

Have a nice day :)


Reply to: