[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#224640: marked as done (only includes i386 kernel package; should perhaps include a -686 optimised kernel for d-i to use)

Your message dated Sat, 22 Nov 2008 00:18:01 +0100
with message-id <20081121231801.GA10627@dedibox.ebzao.info>
and subject line Re: Bug#224640: only includes i386 kernel package; should perhaps include a -686 optimised kernel for d-i to use
has caused the Debian Bug report #224640,
regarding only includes i386 kernel package; should perhaps include a -686 optimised kernel for d-i to use
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

224640: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=224640
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports
Severity: normal

using bootfloppy-image.img and floppy-image.img
uname -a: Linux playpen 2.4.22-1-686 #6 Sat Oct 4 14:09:08 EST 2003 i686
Date:   Tue Nov 18 23:47:05 PST 2003 (This started about 7 PM)
Method: Using daily build netboot images (14Nov03) to do a network
          Machine:      Intel ISP1100 platform with 440BX chipset
          Processor:Intel Celeron 433 Mhz
          Memory:       512 Mb
		  Other:		Intel Network, No CDROM or VGA capability
          Root Device: IBM 18 Gb SCSI on a Qlogic 1040 based HBA
(qla1020 driver)
          Root Size/partition table:
          Root partition wound up being 350 Mb swap and the rest going
into the '/' partition due to issues with trying to boot with grub a
/boot partition.
                        Disk /dev/sda: 18.3 GB, 18351959040 bytes
                        255 heads, 63 sectors/track, 2231 cylinders
                        Units = cylinders of 16065 * 512 = 8225280 bytes
                            Device Boot      Start         End
Blocks   Id  System
                                /dev/sda1   *           1        2188
17575078+  83  Linux
                                /dev/sda2            2189        2231
345397+  82  Linux swap
                        Output of lspci:
                        00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX -
82443BX/ZX/DX Host bridge (AGP disabled) (rev 03)
                        00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB
PIIX4 ISA (rev 02)
                        00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB
PIIX4 IDE (rev 01)
                        00:07.2 USB Controller: Intel Corp.
82371AB/EB/MB PIIX4 USB (rev 01)
                        00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4
ACPI (rev 02)
                        00:0c.0 Ethernet controller: Intel Corp.
82557/8/9 [Ethernet Pro 100] (rev 08)
                        00:0d.0 Ethernet controller: Intel Corp.
82557/8/9 [Ethernet Pro 100] (rev 08)
                        00:0e.0 SCSI storage controller: QLogic Corp.
ISP1020 Fast-wide SCSI (rev 05)
                        Base System Installation Checklist:
                        Initial boot worked:    [O]
                        Configure network HW:   [O]
                        Config network:         [O]
                        Detect CD:              [E]
                        Load installer modules: [O]
                        Detect hard drives:     [O]
                        Partition hard drives:  [E]
                        Create file systems:    [O]
                        Mount partitions:       [O]
                        Install base system:    [O]
                        Install boot loader:    [O]
                        Reboot:                 [E]
                        [O] = OK, [E] = Error (please elaborate below),
[ ] = didn't try it
First off this install was ontop a headless 1U server with no VGA
capable display.  I used a cisco 2511 for a console.  I did not have
full access toa escape and control sequeces becuase of this and this
caused alot of grief, but not all of this was the installer.
The boot sequence went rather smooth.  I ran into the inevitable bad
floppy, but in the several boots I had to run, I never had a problem
with the initial boot. 
The boot sequence came up and asked for my lang, with it defaulting to
english. Detected my hardware including network, and configured it with
DHCP.  This was broke for me until this run, so I was happy. It went
through loading installer modules and establishing the mirror.
This is where I ran into the first problem, it started detecting the
system hardware again becuase the installer wanted to load packages off
the CDROM.  This system does not have a CDROM.  When I tried to get it
to ignore that and say 'No' it stayed in that cycle of trying to
discover the CDROM.  I had to Manually configure the CDROM and then
choose 'No'.  At which point a red error screen came up complaining
about no CDROM drives found on the system.  I continued and I was placed
on Detect CD on the main menu.  I'll refer to this as the 'HW Detect and
CDROM Error' becuase I got this sequences after almost every step
through the install. Why do I have to have a CDROM to do a network
Partitioning the hard drive.
The Installer fail becuase it could not read the partition table on the
drive. I had to initiate a shell and use cfdisk -z to zero out the
partition table.  Once that was done, I returned to the main installer.
At which point I went through:
'HW Detect and CDROM Error'
When I choose to partition the disk within the main installer, it worked
as it should.  This installer should really be able to handle unknown
partition tables without having to resort to the shell. I completed this
and returned to the main menu.
'HW Detect and CDROM Error' and back to step #3.
During configure and Mounting partitions, things worked fine.  Since I
had a large root partition, it hung out for a while at a blank blue
screen, I expected this, but some sort of status might be good for the
general user.
'HW Detect and CDROM Error' and back to step #3.
Installing base system was smooth
'HW Detect and CDROM Error' and back to step #3.
Installing kernel was smooth as well.  The system defaulted to i386
version of the kernel even though I have a i686 based system.  I assume
there is no logic behind that, but using the machine architecture would
be a better and expected default.
'HW Detect and CDROM Error' and back to step #3.
Grub Install
This went smoothly.  My only complaint here is that the verbage around
choosing where to install grub is not intuitive.  For someone not used
to devfs or linux in general, it could cause problems.
Also, I originally configured a /boot partition and set that as active.
I am not sure what the proper way to do a config like this, but it broke
grub on the reboot.  This is a problem I have had for some time, but I
thought I'd see if things had changed since redhat still seemed to do it
that way.  More on grub a little later.
'HW Detect and CDROM Error' and back to step #3.
Finish and reboot.
This went well till it was supposed to reboot. grub error 15 'file not
found'.  I had the grub menu, but I could not get it to boot off the kernel.
root 17 Gb partition which was (hd0,1) and a 100 Mb /boot that was
Nothing I did worked, so I started the installer again. I tried to fix
grub and spent time trying to rescue the system.  This installer does
not allow for rescues that easily.  I seem to recall there is an escape
sequences, but I don't know where it is and there was no mention of it,
so on through the installer till:
'HW Detect and CDROM Error' and back to step #3.
I reinstalled from scratch after trying to boot a coouple of times and
wasting alot of time trying to figure out why grub was messing up.  I
repartitioned the disk to how it is now and reinstalled onto that.  The
install was a repeat of the above, but this configureation was able to
I mentioned that I was on a serial console.  I had to use the installer
as a rescue again in order to get a shell so I could add the boot
parameters back into the grub configuration file: console=ttyS0,9600n8.
Could this not be saved from the inital boot parameters and applied to
the config?  Or at least ask about adding it?  The ability to add these
parmeters in could be critical in installs such as this. And since the
first reboot is a critical configuration step (base-config), not having access like this could i potentially break the install.
As for the seroal console interface, it was slow :) 9600 and painful
becuase of the hitches with the detect CD.  Since this was on a console
of another system, I would get console messages from that system.  The
installer was pretty good about updating the display and keeping it
readable.  So, the display worked pretty well in that regard.
In summary, I think the installer is getting smoother, but has yet a few
major bugs to work out before it is ready for release. I am happy that
the networking issue had been resolved from beta1.  This install, while
frustrating at times, was solveable, and progressed well.  The last
install I was able to make work 17 Oct was far scarier and left me with
a system that was barely salvageable.  This install completed and left
me with a minimal system as I would expect.  I saw a few things that
looked pretty interesting within the installer, like possible future
RAID capability that was exciting.

-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux localhost 2.4.22-1-686 #6 Sat Oct 4 14:09:08 EST 2003 i686

--- End Message ---
--- Begin Message ---
On Sat, Nov 22, 2008 at 12:05:54AM +0100, Frans Pop wrote:
> The installer has always had a "smart" kernel selection mechanism and will 
> install the "best available matching kernel".
> Given the age of this BR I'd say just go ahead and close it.
Closing it.

Simon Paillard

--- End Message ---

Reply to: