[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#698909: installation-reports: successful install in GNOME Boxes using kFreeBSD


On 25/01/13 07:05, Paul Wise wrote:
> It wasn't a complete success, my report contained a few issues that
> could/should be polished up [...]

Not a problem...  I've had a read through and we can follow up on some
things in separate bug reports.

On 25/01/13 05:03, Paul Wise wrote:
> During the partitioning section of the installer, I got this message
> twice, ignoring it worked fine:
> Could not get identity of device /dev/ada0 - Inappropriate ioctl for device

Yes, harmless.  Should be able to silence it by picking out just the
relevant bit from Jeff Epler's patch here:

> The timezone selection section did not have a GeoIP option, instead I
> had to manually select my timezone.

Oh.  Didn't even know that existed.  Do you know where specifically it's
implemented in code?

> The mirror selection did not default to http.debian.net nor to
> cdn.debian.net, instead I had to either manually navigate the long list
> of countries and mirrors or manually enter a server.

Is this any different from GNU/Linux?  AFAIK neither of those are
intended to be defaults yet, as they're 'unofficial' *.d.n services.
See also #697488...

> When I manually entered http.debian.net, it decided that the mirror was
> bad and forced me to enter another mirror. The installer logs indicate
> it couldn't find Suite|Codename in the Release file, trying the wget
> command it used manually worked fine though.

This sounds familiar.  I though maybe http.d.n offers mirrors sometimes
that don't carry wheezy/sid suites for GNU/kFreeBSD.

Personally I still use gb.kfreebsd-amd64.mirror.debian.net for now.

> I note that the automatic reports listed below contain some errors;
> things not being mounted, commands not being found:

Ahhh this is really cool.  I was already in the middle of making
something to capture and summarise this kind of thing, from syslog
during test installs.

These are all used by the installation-report report-hw script, so not
really installer bugs:

> /sys/bus
> free
> dfbinfo

/sys/bus doesn't exist but maybe there's a suitable sysctl to use instead.

Fortunately d-i's lowmem code already uses /proc/meminfo, not 'free'.

dfbinfo is built for GNU/kFreeBSD, it works, and would be nice to see
its output in the installation-report.  It just wasn't present;  an
undeclared dependency/recommends on libdirectfb-bin I suppose?

> partman: mkfs.ufs:
> partman: Cannot retrieve operator gid, using gid 0.

mkfs.ufs functions okay on an installed system.  A .snap directory uses
the operator gid.  In this case it falls back to gid 0 with no other error.

The stripped-down /etc/group in d-i doesn't have operator.  We could
maybe ask for it to be added (in rootskel).

> Same for Xorg.0.log:
> [     3.005] (WW) Warning, couldn't open module qxl
> [     3.005] (EE) Failed to load module "qxl" (module does not exist, 0)
> [     3.006] (WW) Warning, couldn't open module fbdev
> [     3.006] (EE) Failed to load module "fbdev" (module does not exist, 0)
> [     3.008] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
> [     3.069] (WW) VESA(0): Unable to estimate virtual size
> [     3.069] (WW) VESA(0): No valid modes left. Trying less strict filter...
> [     3.069] (WW) VESA(0): Unable to estimate virtual size
> [     3.228] (WW) <default pointer>: No Device specified, looking for one...

Were you able to check you had working display+mouse+keyboard in Xorg?

> [     3.307] (WW) fcntl(8, O_ASYNC): Inappropriate ioctl for device

That's worrying.  It should be a supported flag.

TODO:  look at some other cases:

Thanks for this!
Steven Chamberlain

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: