[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: xorg pointer (mouse)

On Tuesday 02 February 2010 10:26:44 Petr Salinger wrote:
> >> My mouse is a usb device. lshal shows nothing for it
> >> even though it shows up in dmesg. I have not tried a PS/2 mouse.
> >>
> >> So I am still without a working X11 system...
> I borrowed USB mouse from another computer, it works fine for me:
> Log and xorg.conf attached, from dmesg:
> ugen4.2: <Logitech> at usbus4
> ums0: <Logitech USB Optical Mouse, class 0/0, rev 2.00/43.01, addr 2> on
>  usbus4 ums0: 8 buttons and [XYZ] coordinates ID=0
> orion-bsd:/var/log# dpkg -la | grep xorg
> ii  xorg-docs-core                         1:1.5-1                         
>  Core documentation for the X.org X Window System ii  xserver-xorg         
>                   1:7.5+3                          the X.Org X server ii 
>  xserver-xorg-core                      2:1.7.4-2                       
>  Xorg X server - core server ii  xserver-xorg-input-all                
>  1:7.5+3                          the X.Org X server -- input driver
>  metapackage ii  xserver-xorg-input-kbd                 1:1.4.0-1          
>               X.Org X server -- keyboard input driver ii 
>  xserver-xorg-input-mouse               1:1.5.0-1                       
>  X.Org X server -- mouse input driver ii  xserver-xorg-video-nv            
>       1:2.1.15-1                       X.Org X server -- NV display driver
> It works for me regardless hald runs or not.
> Petr

Strange, strange:

My usb mouse is now working; I do not know how,
yet I still see errors in Xorg.0.log (and still no sign of it in hal).
At least the cursor moves, and X11 is usable!


(**) Option "Protocol" "auto"
(**) Default mouse: Device: "/dev/ums0"
(**) Default mouse: Protocol: "auto"
(**) Option "SendCoreEvents" "true"
(**) Default mouse: always reports core events
(**) Option "Device" "/dev/ums0"
(==) Default mouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Default mouse: ZAxisMapping: buttons 4 and 5
(**) Default mouse: Buttons: 9
(**) Default mouse: Sensitivity: 1
(II) XINPUT: Adding extended input device "Default mouse" (type: MOUSE)
(**) Default mouse: (accel) keeping acceleration scheme 1
(**) Default mouse: (accel) acceleration profile 0
(II) Default mouse: SetupAuto: hw.iftype is 5, hw.model is 0
(II) Default mouse: SetupAuto: protocol is SysMouse
(WW) fcntl(8, F_SETOWN): Inappropriate ioctl for device
(**) Default mouse: Device: "/dev/ums0"
(**) Default mouse: Protocol: "auto"
(**) Option "SendCoreEvents" "true"
(**) Option "CorePointer"
(**) Default mouse: always reports core events
(**) Option "Device" "/dev/ums0"
(EE) xf86OpenSerial: Cannot open device /dev/ums0
        Device or resource busy.
(EE) Default mouse: cannot open input device
(EE) PreInit failed for input device "Default mouse"
(II) UnloadModule: "mouse"

Reply to: