[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Xorg7.4 doesn't work

Axel Beckert a écrit :
> Hi,
> On Wed, Jun 10, 2009 at 11:32:58AM +0200, Aurelien Jarno wrote:
>>>> I think that xorg needs hal to work correctly but hal is not
>>>> suitable for kFreeBSD.
>>> This is a known problem, but the X.org maintainers refuse to
>>> downgrade the recently added Depends to a Recommends (which it
>>> technically is). They even use all CAPS-LOCK lines to defend this
>>> very unpopular decision.
>> There is no need to, hal should be available and should work on
>> GNU/kFreeBSD.
> I haven't restarted X since the upgrade because I feared problems
> after all the hassles I had on other boxes with 7.4 and it really
> worked smooth with 7.3.
> So I just restarted X and neither USB mouse nor USB keyboard work
> anymore. Great.
> It works neither with the xorg.conf which worked fine for 7.3 nor with
> all the input devices commented out nor without xorg.conf at all.
> The log says:
> | (II) Cannot locate a core pointer device.
> | (II) Cannot locate a core keyboard device.
> | (II) The server relies on HAL to provide the list of input devices.
> |         If no devices become available, reconfigure HAL or disable
> | 	  AllowEmptyInput.
> But neither Xorg(1) nor X(7) say anything about HAL.
> If I do "dpkg-reconfigure -plow hal", I just get the following:
> | # dpkg-reconfigure -plow hal
> | Stopping Hardware abstraction layer: hald.
> | Reloading system message bus config...done.
> | Can't start Hardware abstraction layer - enable inotify support in your kernel failed!
> Haha. And no, I wouldn't call that "working on GNU/kFreeBSD".

It's a mistake, the init script hasn't been correctly patched to remove
this check. Could you please try to remove it manually from
/etc/init.d/hal? You may have other lines to remove too.

Aurelien Jarno	                        GPG: 1024D/F1BCDB73
aurelien@aurel32.net                 http://www.aurel32.net

Reply to: