[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Xorg7.4 doesn't work


On Wed, Jun 10, 2009 at 11:32:58AM +0200, Aurelien Jarno wrote:
> > > I think that xorg needs hal to work correctly but hal is not
> > > suitable for kFreeBSD.
> > 
> > This is a known problem, but the X.org maintainers refuse to
> > downgrade the recently added Depends to a Recommends (which it
> > technically is). They even use all CAPS-LOCK lines to defend this
> > very unpopular decision.
> There is no need to, hal should be available and should work on
> GNU/kFreeBSD.

I haven't restarted X since the upgrade because I feared problems
after all the hassles I had on other boxes with 7.4 and it really
worked smooth with 7.3.

So I just restarted X and neither USB mouse nor USB keyboard work
anymore. Great.

It works neither with the xorg.conf which worked fine for 7.3 nor with
all the input devices commented out nor without xorg.conf at all.

The log says:

| (II) Cannot locate a core pointer device.
| (II) Cannot locate a core keyboard device.
| (II) The server relies on HAL to provide the list of input devices.
|         If no devices become available, reconfigure HAL or disable
| 	  AllowEmptyInput.

But neither Xorg(1) nor X(7) say anything about HAL.

If I do "dpkg-reconfigure -plow hal", I just get the following:

| # dpkg-reconfigure -plow hal
| Stopping Hardware abstraction layer: hald.
| Reloading system message bus config...done.
| Can't start Hardware abstraction layer - enable inotify support in your kernel failed!

Haha. And no, I wouldn't call that "working on GNU/kFreeBSD".

| # uname -a
| GNU/kFreeBSD metisse 7.1-1-686-smp #0 Tue Apr 14 01:03:59 CEST 2009 i686 i386 Intel(R) Atom(TM) CPU N270   @ 1.60GHz GNU/kFreeBSD

The only file under /etc/hal/ doesn't say anything about inotify and
hald has no command line option to disable inotify, at least not
according to the man page.

I know there are people working on inotify for FreeBSD since years,
but I haven't noticed anything of that on Debian GNU/kFreeBSD yet. Do
we have that already? Is it usable?

Adding the following to my xorg.conf at least got the keyboard back:

| Section "ServerFlags"
|         Option "AllowEmptyInput" "no"
| EndSection

But the mouse still doesn't work.

According to /usr/share/doc/xserver-xorg/NEWS.Debian.gz console-setup
is where keyboard and mouse are configured. But "dpkg-reconfigure
-plow console-setup" didn't help either and also didn't ask me
anything about a mouse.

Anyway, I didn't manage to get my USB mouse working again, so X on
kFreeBSD can be considered quite broken at least machines without
legacy ports like many modern low-power devices, e.g. the EeeBox.

> If it is not the case, we should concentrate our efforts on fixing
> it.

So yeah, 7.4 is quite borked currently, especially the hal part. 7.3
worked fine.

		Regards, Axel
Axel Beckert - abe@deuxchevaux.org, abe@noone.org - http://noone.org/abe/

Reply to: