[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#947449: networking on Olimex Lime2 (Allwinner A20)


Geert Stappers kirjoitti 27.12.2019 klo 19.24:
> Quoting https://linux-sunxi.org/Olimex_A20-OLinuXino-Lime2#GMAC_u-boot_config
>  GMAC u-boot config
>  From Revision H onward, the Lime2 comes with a Microchip KSZ9031
>  gigabit ethernet phyceiver. These need the following line added to the
>  u-boot config (in configs/A20-OLinuXino-Lime2_defconfig):
>  Do not set this to another value but 3.
>  This Microchip PHY chip is also getting significantly hotter than the
>  old Realtek RTL8201CP PHY. 
> Please report back how usefull this message was.

So I tried to build u-boot myself with the CONFIG_GMAC_TX_DELAY=3
directive, and I also tried to blindly copy the SPI+bootloader from an
Armbian image (in which the networking works properly), but in neither
case networking works (the other aspects are fine, the system boots
without problems, so I assume I did not break anything myself).

So I guess the issue lies elsewhere than in u-boot (perhaps the kernel?).


Reply to: