[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#911133: Graphical installer

On 2018-10-19, Ben Hutchings wrote:
> On Thu, 2018-10-18 at 23:43 -0700, Vagrant Cascadian wrote:
>> There are at least two arm64 laptops, but as far as I know they both
>> currently just support simplefb, though I'm not sure what needs to
>> change in debian-installer to support them; just tried the pinebook
>> earlier today without much luck getting d-i running on the tty displayed
>> on the LCD.
> Can you check whether u-boot is updating the simple-framebuffer device
> tree node?  There should be a
> /proc/device-tree/chosen/framebuffer@<address> directory containing
> status, width, height, etc.  That would help to isolate the problem to
> either u-boot or the kernel.

Booted using u-boot loading the kernel using extlinux.conf, LCD works

$ uname -a
Linux pbkb 4.18.0-2-arm64 #1 SMP Debian 4.18.10-2 (2018-10-07) aarch64 GNU/Linux

$ head /proc/device-tree/chosen/framebuffer@be000000/* ; echo
==> /proc/device-tree/chosen/framebuffer@be000000/allwinner,pipeline <==
==> /proc/device-tree/chosen/framebuffer@be000000/clocks <==
==> /proc/device-tree/chosen/framebuffer@be000000/compatible <==
==> /proc/device-tree/chosen/framebuffer@be000000/dvdd12-supply <==

==> /proc/device-tree/chosen/framebuffer@be000000/dvdd25-supply <==

==> /proc/device-tree/chosen/framebuffer@be000000/format <==
==> /proc/device-tree/chosen/framebuffer@be000000/height <==

==> /proc/device-tree/chosen/framebuffer@be000000/name <==
==> /proc/device-tree/chosen/framebuffer@be000000/panel-supply <==

==> /proc/device-tree/chosen/framebuffer@be000000/reg <==
==> /proc/device-tree/chosen/framebuffer@be000000/status <==
==> /proc/device-tree/chosen/framebuffer@be000000/stride <==
==> /proc/device-tree/chosen/framebuffer@be000000/width <==

$ head /proc/device-tree/chosen/framebuffer@be000000/* | sha256sum
e87568d4e7086f45c02e4fe25bdddca9c0808eb519d68100db3cecf82dd260c5  -

Booting the d-i daily kernel, I got the same checksum:

# uname -a
Linux (none) 4.18.0-1-arm64 #1 SMP Debian 4.18.6-1 (2018-09-06) aarch64 GNU/Linux

# head /proc/device-tree/chosen/framebuffer@be000000/* | sha256sum
e87568d4e7086f45c02e4fe25bdddca9c0808eb519d68100db3cecf82dd260c5  -

But, the LCD display worked this time.

A cold boot just now failed, and I'm unable to get a console... I'm
guessing the LCD is intermittant, at least with 4.18.x. The LCD has been
pretty reliable with linux 4.19-rc7 from experimental. So this aspect of
this issue may just go away once d-i uses linux 4.19.

There may also be differences booting with u-boot's EFI support (d-i's
mini.iso) and using u-boot's extlinux.conf support, which is what I've
been mostly testing.

Needs some further exploration.

live well,

Attachment: signature.asc
Description: PGP signature

Reply to: