[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Armel: Debian installer freeezes (GuruPlug Server plus)

Sorry, english is not my native language (I'm finnish), so I have been unclear on my previous posts.

I have followed instructions literally, but installer freezes and text "Uncompressing Linux..." appears on terminal window.

On "https://www.cyrius.com/debian/kirkwood/sheevaplug/install"; separate ftd -blob file is indeed not loaded, but when I load fdt kernel
finally boots but cannot find rootfile system.

There is some information on "Debian armel installation" guide for uInitrd relocation problems and advice to se "bootm_size" to default value. Unfortunatelly that does not work if original U-boot version is pre-2014, becouse of bootm_size value is not set at all. I tried to se "bootm_size" value manually by U-boot without success, only way to get kernel to boot is load fdt separately.

Martin Michlmayr kirjoitti 1.3.2018 15:11:
(Adding Ian Campbell.)

Ok, I didn't notice the version of u-boot from the log you posted and
went on what you wrote.

However, looking at the log file again, I notice you're loading the
DTB file separately.

You say you follow my installation instructions but clearly you're
not.  In Debian installer, for the various plug devices, we append to
the DTB at the end of the kernel rather than loading it separately.

Can you please follow the instructions at
https://www.cyrius.com/debian/kirkwood/sheevaplug/install/ and post
the output of that?

* Kari Tanninen <otmen@elisanet.fi> [2018-03-01 15:01]:
I'm using Debian stretch U-boot version (U-boot version number is visible on
the log-file). I have tried Debian "buster" U-boot version too, but it
freezes at "Setting egiga0" point. There is warning on "Debian Armel
installation guide", that U-boot does update kernel variables only on fresh installation, if first U-boot version is older than 2014, there will be
problems becouse of "bootm_size" variable is missing and default value
cannot be set.

Flattened device tree -mechanism is not using those "ATAG" global
kernel/U-boot -variables, but problem is missing U-boot "boot_args"
-variable, too.

Fdt-file includes that "Chosen" -field for command line parameters and
U-boot has a commands to resize fdt -file and append command line parameters
to it before actual boot.

U-boot sets and can read correctly that fdt-file "chosen" part. U-boot
kprint line for that "chosen" value is visible on log-file.

Martin Michlmayr kirjoitti 1.3.2018 14:02:
> * Kari Tanninen <otmen@elisanet.fi> [2018-03-01 11:26]:
> > HW: Guruplug Server plus with JTAG-box (ARMv5-family)
> > original U-boot pre-2014
> ...
> > Is there any fix-up/work-aroud trick available or is new kernel
> > compiling
> > only option?
> I've never had a GuruPlug so I cannot really comment but why are you
> using the pre-2014 u-boot version?  I cannot remember all the
> differences of the u-boot versions of the installation page says you
> should upgrade your u-boot before installing Debian.  Maybe you can
> give this a try.
> Based on the logs you posted, it seems to me that the kernel and
> ramdisk are loaded but the kernel doesn't see the ramdisk, leading to
> the "no root" issue.

Reply to: