[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#861083: Fails to boot installed system


On Tue, Apr 25, 2017 at 03:10:14AM +0200, Cyril Brulebois wrote:
> Did you try some kernel command line parameters, like enabling debug,
> disabling quiet, maybe disabling modesetting? You could also try adding
> netconsole parameters to send kernel messages elsewhere if you're
> getting no output at all.

Thank you for the suggestions.

I've tried adding "debug", removing "quiet", and adding "nomodeset".
Is that what you're referring to?  I just tried using netconsole, but
the system doesn't have an RJ45 jack, the Wi-Fi adapter requires
firmware, and the wireless network requires a password, so something
in there caused it not to work.  :(

> Differences between installation and installed systems include: plain
> init versus systemd, fbdev being used for Xorg in d-i; also, sometimes,
> some modules are missing from the initrd because initramfs-tools didn't
> include them (while d-i uses different codepaths to enable hardware
> support). I assume yours is using the default MODULES=most anyway
> (unless you tweaked it)?

I was able to get the system to boot by installing LILO instead of
GRUB.  Do you have any suggestions for investigating why GRUB doesn't


Reply to: