[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Booting Debian on NVMe Dirive with killer E2400 ethernet next to Impossible!!!!

Finally got it to work!! here is the procedure, I hope it helps someone else:

Step 1 start the installation with the Debian DVD and go through it unitl it sais Grub failed

Step 2 in a separate USB memory and with a working debian system do:

sudo apt-get -t jessie-backports download grub-efi-amd64
sudo apt-get -t jessie-backports download grub2-common
sudo apt-get -t jessie-backports download grub-efi-amd64-bin
sudo apt-get -t jessie-backports download efibootmngr
sudo apt-get -t jessie-backports download libefvar0

sudo apt-get -t jessie-backports download linux-base
sudo apt-get -t jessie-backports download Initramfs-tools
sudo apt-get -t jessie-backports download linux-image-4XXXXXXX (i dont remember 
just pick your 4.x image)

Step3 on the system that you are installing go into a terminal 

cd /target
mount --rbind /sys sys/
mount --rbind /dev dev/
mount --rbind /run run/
chroot . /bin/bash

Step 4 insert your usb and do cd /var/ ls and figure out its name usually /dev/sdb1

Step 5 mount your usb with the packages
mkdir ./cosas 
mount /dev/sdb1 ./cosas
cd cosas

Step 6 start installing the linux kernel packages, then the grub starting in this order

Step 7 
exit the console by typing exit

step 8 
finish the installation 


step 10 Enjoy.

On Sun, Oct 23, 2016 at 7:26 PM, Lennart Sorensen <lsorense@csclub.uwaterloo.ca> wrote:
On Sun, Oct 23, 2016 at 01:43:49PM -0700, Humberto Hassey wrote:
> Hello I am a Debian user and just bought a nice laptop from system 76, I
> wiped ubuntu and proceed to install Debian, well it turns our that Debian
> does not recognize my network card, and the Grub packed on the installer
> does not recognize the NVMe drive correctly, so I can not boot, nor connect
> to the internet in order to download the grub-efi from backports..
> I tried getting a shell from the install DVD and chrooting into the
> installation to install the previously downloaded grub-efi-amd64 and
> linux-image 4.7xxx from backports, but the installation fails saying there
> are unmet dependencies...

On new hardware, you might be better of trying stretch instead, which
is probably only about half a year or so from release anyhow.

I know NVMe install works, because I tried it, with the testing (stretch)
installer.  Jessie does not support it, at least last I checked.

Len Sorensen

Reply to: