[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#772898: win32-loader testing and newer fails with TRANSLATE error

Bernhard Übelacker <bernhardu@vr-web.de> (2014-12-12):
> Hello,
> probably I have found something more.
> I tested in a VM with a more recent windows version, therefore I cannot
> sure that this is the reason you saw (having to run win32-loader with
> compatibility set to windows 7 on a windows 8.1 32bit).
> I used the version from [1].
> Because you already hinted to the direction of loading nsisdl.dll I
> watched an installation attempt by ProcMon [2] and found after the nsisdl.dll
> was accessed it tried to load a file libwinpthread-1.dll which it could not find.
> Opening nsisdl.dll in Dependency Walker [4] it is shown that it is really linked
> against libwinpthread-1.dll.
> So I downloaded package mingw-w64-i686-dev_3.2.0-2_all.deb [5], extracted the content
> to some directory and started a cmd with elevated rights and added the path.
>     set PATH=E:\mingw-w64-i686-dev_3.2.0-2_all\usr\i686-w64-mingw32\lib;%PATH%
> Then started win32-loader from this cmd and it worked and finished installation.
> So this dll could be added to the installer and extracted along the nsisdl.dll, or
> the dll needs to be statically linked against libwinpthread-1?

Looks like a pretty thorough investigation, many thanks!

Hopefully Didier will follow up shortly with a possible patch or even
prospective package.

Really happy to see Windows-savvy people helping us. :)


Attachment: signature.asc
Description: Digital signature

Reply to: