[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#757711: netcfg: promptly kills dhclient, deconfigures interface

Steven Chamberlain <steven@pyro.eu.org> (2014-08-12):
> found 757711 1.108+deb7u1
> thanks
> On 11/08/14 23:57, Cyril Brulebois wrote:
> >>> found 757711 netcfg/1.118
> >>> severity 757711 grave
> > 
> > Eeww, I missed that.
> Sorry, assumed you'd seen this...  though I did feel the severity was
> justified since DHCP is the most common use-case.  I also don't know yet
> it if this is really kfreebsd-specific?

Well, given the amount of testing I've been doing lately (mostly if not
only with DHCP), I would have caught it on Linux if it hadn't been

> > Steven, if you're going to raise severity to something RC, *please*
> > check whether the version in testing is also affected.
> I really tried to do this before the ~1800UTC deadline, which I think is
> when Britney takes a snapshot of BTS state.  I'm afraid it didn't go
> smoothly and I ran out of time.  And so that left only two options:
> * cheat:  downgrade the bug against my own judgement, or tentatively
> mark it as affecting testing - with a slight chance of introducing a new
> bug otherwise,

Given the following changelog entry, I think it would have been a safe
thing to do, even without looking at the actual changes:

I wouldn't call it cheating, BTW. :)

If you plan to perform some testing, all good, found/notfound versions
can be fixed (no pun intended) afterwards. In the worst case, udeb
freeze is in place anyway, so I can only yell at myself (as a maintainer
in this particular case and/or as d-i release manager in the general
case) if I unblocked packages introducing regressions:

> * or leave it this way, even if it delays migration for a day, until
> someone else or I can figure this out for sure.

Anyway, that's not the end of the world, I was only trying to give
general directions to avoid such things in the future.

See my summary to debian-{boot,cd,release}@ (towards the end of the

> Anyhow I've tested as far back as the wheezy version of netcfg and
> seemingly, that shows the same issue, suggesting it was a change
> somewhere else (like isc-dhcp-client-udeb) that caused this bug to
> appear.  It still may be netcfg where this needs to be fixed, I don't
> know yet.

That I don't know. Maybe try and compare with netcfg + dhcp client du
jour on Linux, and see whether netcfg's behaviour is different in both
cases, or the dhcp client's one, or the kernel's one.

At least that's what I'd try out of the blue if I were to debug this.
(I'm not volunteering. :p)


Attachment: signature.asc
Description: Digital signature

Reply to: