[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: netcfg questions not asked with priority=critical. HD partition recipe.

On Sun, Apr 14, 2013 at 09:13:56PM +0200, Samuel Thibault wrote:
> Hello,
> Regid Ichira, le Sat 13 Apr 2013 19:37:14 +0300, a ?crit :
> > 1. With all the following conditions:
> >    1.1 auto=true
> >    1.2 no priority defined by me
> >    1.3 dhcp server supplies the host and domain names
> >    1.4 d-i netcfg/get_hostname string foo and 
> >        d-i netcfg/get_domain string bar
> >        are set in the preseeded file.
> >    the netcfg settings had no effect.  I was asked to confirm the 
> >    host and domain names supplied by the dhcp server.
> I have done the following, which I believe is equivalent to what you
> have done:
> - remastered debian-wheezy-DI-rc1-amd64-netinst-1.iso, to add a
>   preseed.cfg file at its root, containing
>   d-i netcfg/get_hostname string foo
>   d-i netcfg/get_domain string bar
> - tinkered qemu so it reports a dhcp domain search name too (dhcp option
> 15)
> - ran qemu this way:
> qemu -cdrom netinst.iso -net nic -net user,hostname=foo2
> - at boot prompt, appended auto=true preseed/file=/cdrom/preseed.cfg
> (so without setting any priority)

  What I did?

I have booted the machine with the following syslinux entry:

    label  di
            linux  d-i/linux-20130211
            initrd d-i/initrd.gz-20130211
            append vga=791 ramdisk_size=10240 root=/dev/rd/0 \
                   devfs=mount,dall rw auto=true priority=critical \

line continuation are for presentation purposes only.  That syslinux
entry is for syslinux that I use to boot the machine.  It has nothing
to do with the syslinux the installer might be using.  My reports to
the list were when I also tried just auto, without priority at all.  
Or just auto=true, again without priority.  Obviously, when trying
preseeding, I always kept the url directive.

> And I did not get asked for the hostname or domain name, and running
> debconf-get netcfg/get_hostname (and netcfg/get_domain) shows that the
> values returned by dhcp have properly been taken into account.
> I'm only asked for confirmation of the values returned by dhcp when I do
> not pass the preseed/file boot option.
> So I can only see it working as expected, and there must be something
> that you and I are doing differently.

  I am not familiar with qemu.  I have only general understaning about
what you did.  I do believe that the main difference between what both
of us did is the way the installer is booted.  I think you are using
the somewhat hiden syslinux of the installer.  You did wrote that you 
appended parameters at the boot prompt.  While I don't get the 
installer boot prompt at all.  For me, after a period of blank screen,
I get the kernel boot messages.  And then the installer get running.
The only place I have a chance to add parameters to the installer
apriory is in my syslinux entry from above.  Or in the preseeding file.
I do think that what you and me get is consistent with the posts of
Philip Hands, 
http://lists.debian.org/debian-boot/2013/04/msg00171.html, and
Brian Potkin,
http://lists.debian.org/debian-boot/2013/04/msg00180.html, at the
beginnig of this thread.  It could also be a matter of the initrd.  I
can't tell for sure where I got the kernel+initrd from.  I had
difficultis finding a pair that wouldn't cause a kernel panic. 

> How is your dhcp server returning
> the hostname and domain name? Is it perhaps using the fqdn option
> instead of the separate host name (12) + domain name (15)?

  It has 

    option domain-name "domain";
    use-host-decl-names  on;

with host hostname_not_fqdn { ... } blocks In dhcpd.conf.  Doesn't
that returnes separate host name (12) + domain name (15)?  As far as
I remember, I saw seperate lines when examining the installer logs on
vt4.  Or was it, with nano, on vt2?

> Are you sure 
> that preseeding actually works for you?

  I am sure preseeding actually works for me.  For example, when
attemting to have a preseeded partition recipe I did get related
suggestion by the installer.

> You could for instance try to
> also put
> d-i passwd/root-password password r00tme
> d-i passwd/root-password-again password r00tme
> to check that the root password question is properly skipped.  If it's
> not skipped, the preseeding has not worked and that's where the issue
> is, not in netcfg.

  I will try it soon.  I do hope to finally install the machine.

> > 2. Setting priority=critical, and everything else is like in 1, made
> >    the verfication questions disappear.  
> That is not surprising, as these are not of critical priority.

Reply to: