[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How the debian-boot installer fucked up my system

My answers below.

On Tue, 26 Jun 2012 11:11:35 +0200
Goswin von Brederlow <goswin-v-b@web.de> wrote:

> Félix Arreola Rodríguez <fgatuno.123@gmail.com> writes:
> > Oops, I forget CC the mailing list, Forwarding.
> >
> > El lun, 25-06-2012 a las 16:22 +0200, Matthias Richerzhagen
> > escribió:
> >> Hello,
> >> 
> >> As i have no optical drive in my Computer and i didn't wanted to
> >> invest time to get a boot USB stick running i decided to use the
> >> debian installer from goodby-microsoft.
> >> The first problem i encountered was, that the firmware for my
> >> ethernet card was not supplied with the installer, so i took a USB
> >> stick and copied the firmware files. 
> >
> > The Debian Installer can't have firmware files (or at least, the
> > non-free ones), this because it violates the DFSG [1]
> >
> >> That first of course didn't work,
> >> because it was NTFS formatted. But that was pretty obvious, so i
> >> could resolve that easily. (But this disability to read NTFS
> >> should be noted somewhere inside the installer itself)
> >
> > The NTFS filesystem is privative, and is hardly usable and private
> > again, this is why is not supported in the d-i.
> > As my opinion, NTFS is a poor choice for a USB stick.
> NTFS-3g fuse filesystem works just fine. There is no reason not to
> include that in d-i. NTFS might be a poor choice for a USB stick but
> hardly an uncommon one.
I would like a note on the screen, that says "insert your removable
media now", that informs me about "Supported file systems
are: ..."

> >> After the installer had loaded its components from the internet i
> >> re-sized a partition on my hard drive (actually my Windows boot
> >> partition) to have some space for Debian and installed Debian
> >> there. The next step was to install GRUB. That was the first step
> >> that failed, with an error message: "grub-install /dev/sda"
> >> failed. BUT /dev/sda is the USB device i loaded the firmware for my
> >> ethernet card from! (like i could see from the partition manager)
> Did you load the firmware from sda itself or a partition of sda?
> In the later case grub should have worked and it would be interesting
> to find out why it didn't.

well. /dev/sda is the device for my usbstick, and it actually has
only one fat16-partition on it, which the firmware is copied to.
(That's what it looked like in the partition-manager)
> > The actual squeeze installer ask if is ok installing grub
> > on /dev/sda, if you choice no, you can specify other device. If
> > this was no the case, maybe the d-i from goodbye-microsft is a
> > little out of date.
> Just some background information here. The order in which devices
> appear is somewhat random, it varies between different systems and
> can even change on every boot. Also asking the bios for the boot
> order, i.e. which device it boots from, is highly unreliable.
> So unless you have only one "harddisk" it becomes quite hard, if not
> impossible in general, to find the right device to install grub
> to. Well, D-I (or rather grub-common I think) doesn't try anything
> fancy and instead asks you about it.
Haven't seen that question.
It asks me if I want it installed to the MBR, which for me sounded
right (as i always did it like that) and grub had discovered all my
other operating systems (only the broken windows 7).
Was that the mistake i made?

> >> But installing LILO worked fine.
> >> Finishing installation - rebooting - Kernel Panic.
> >> stuck at initrd shell(?) couldt not find a kernel to load?
> >> something like that. 
> >> "Oh damn, but i still have my Windows System"
> >> But windows is stuck at the boot screen and says, that the
> >> partition is corrupted and that it cannot fix that.
> >> 
> >> So in short:
> >> The debian installer wanted to install grub on my usb
> >> stick /dev/sda instead of /dev/sdb (hard drive)
> >> The partition re-size destroyed my windows boot partition (Well i
> >> cannot really blame you for that, because of the big warning about
> >> POSSIBLE data loss, but it worked for me on another system without
> >> the installer several times pretty well, so i was not worried :/)
> >
> > Always there will be problems with NTFS partitions, in this case
> > blame the fragmentation in NTFS. You should always defrag the
> > partition before re-sizing it. *Other* option is let windows doing
> > the resizing thing, he can't kill him self (Or he could?).
> >
> >> 
> >> Now i got a debian install usbstick, which worked fine out of the
> >> box, but i want to share my experiences with you and have the
> >> hope, that nobody has to make these experiences again.
> Did it work because now the usb stick ended up as /dev/sdb and
> installing grub on the real harddisk worked? Or did it manage to make
> your USB stick bootable?
It worked, because my usb stick ended up as /dev/sd[^a].

> > Maybe this supports my theory of the d-i out of date.
> Would be nice to have version information of the installer to be
> certain.
I still can boot the installer, so i may provide you with that
information, if you can tell me where to look.


Reply to: