[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

How the debian-boot installer fucked up my system


As i have no optical drive in my Computer and i didn't wanted to invest
time to get a boot USB stick running i decided to use the debian
installer from goodby-microsoft.
The first problem i encountered was, that the firmware for my ethernet
card was not supplied with the installer, so i took a USB stick
and copied the firmware files. That first of course didn't work,
because it was NTFS formatted. But that was pretty obvious, so i could
resolve that easily. (But this disability to read NTFS should be noted
somewhere inside the installer itself) \
After the installer had loaded its components from the internet i
re-sized a partition on my hard drive (actually my Windows boot
partition) to have some space for Debian and installed Debian there.
The next step was to install GRUB. That was the first step that failed,
with an error message: "grub-install /dev/sda" failed. 
BUT /dev/sda is the USB device i loaded the firmware for my
ethernet card from! (like i could see from the partition manager)
But installing LILO worked fine.
Finishing installation - rebooting - Kernel Panic.
stuck at initrd shell(?) couldt not find a kernel to load? something
like that. 
"Oh damn, but i still have my Windows System"
But windows is stuck at the boot screen and says, that the
partition is corrupted and that it cannot fix that.

So in short:
The debian installer wanted to install grub on my usb stick /dev/sda
instead of /dev/sdb (hard drive)
The partition re-size destroyed my windows boot partition (Well i cannot
really blame you for that, because of the big warning about POSSIBLE
data loss, but it worked for me on another system without the
installer several times pretty well, so i was not worried :/)

Now i got a debian install usbstick, which worked fine out of the box,
but i want to share my experiences with you and have the hope, that
nobody has to make these experiences again.


Reply to: