[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#626299: debian-installer: installer broken on armel - "Can't check signature: public key not found"

Martin Michlmayr wrote:
> * booster@wolke7.net <booster@wolke7.net> [2011-05-11 19:21]:
>> I'm using the latest installer image from the link you mentioned
>> and I also tried different mirrors with the same result.
> I just checked the latest debian-installer image and it definitely
> contains the GPG key 473041FA, which the installer is complaining
> about in the logs you sent.
> I believe you're not using the latest installer.
> Look at the logs you sent:
>> May 11 17:10:41 kernel: [    0.000000] Linux version 2.6.32-5-kirkwood (Debian 2.6.32-15) (ben@decadent.org.uk) (gcc version 4.3.5 (Debian 4.3.5-1) ) #1 Thu Jun 3 15:54:38 UTC 2010
> The kernel is built in June 2010.  But the latest Debian installer
> image from
> ftp://ftp.debian.org/debian/dists/stable/main/installer-armel/current/images/kirkwood/network-console/qnap/ts-219/
> should, afaik, contain a much newer kernel (one from March 2011).
> Can you download the installer image again and try once more?
I downloaded the installer files again from the ftp site and have done a
new test with the same result.

After some debugging at the system with the installer running I found
that in the shell script
/usr/lib/debian-installer/retriever/net-retriever 'gpgv' is called (line
96ff). When I call this command
at the running system I get the following output:
~ # gpgv --status-fd 1 --keyring /usr/share/keyrings/archive.gpg
--ignore-time-conflict /tmp/net-retriever-1558-Release.gpg
gpgv: Signature made Sat May 14 02:23:49 2011 UTC using RSA key ID 473041FA
[GNUPG:] ERRSIG AED4B06F473041FA 1 2 00 1305339829 9
gpgv: Can't check signature: public key not found

The start of file /tmp/net-retriever-1558-Release contains the following

Origin: Debian
Label: Debian
Suite: testing
Codename: wheezy
Date: Sat, 14 May 2011 02:23:28 UTC
Valid-Until: Sat, 21 May 2011 02:23:28 UTC
Architectures: amd64 armel i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips
mipsel powerpc s390 sparc
Components: main contrib non-free
Description: Debian x.y Testing distribution - Not Released

So, the problem seems to be that the wrong Release file is downloaded by
the installer.

Reply to: